The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-10-2019, 03:37 PM
OverCluster OverCluster is offline
Registered User
OverCluster's PC Specs
 
Join Date: Apr 2019
Posts: 8
POST ID # = 1010798
OverCluster Reputation: 10
Default Corsair Ironclaw RGB lose connection

Hi,

I'm currently using a Corsair Ironclaw RGB mouse. The thing is, the mouse disconnects when using vía 2.4Ghz connection.

When I turn it on, it won't move the cursor. Sometimes I fix it by unplugging the USB Dongle in the front USB 2.0 port, and other times i just have with the wired.

I wanted to know if there is a specific method to resincrhonize again. I know that pressing one or more keys the mouse starts searching for the USB Dongle.

Thanks so much,
Reply With Quote


  #2  
Old 07-10-2019, 05:16 PM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 8,767
POST ID # = 1010808
c-attack c-attack Reputation: 104
Default

I had a short bout with this when it first came out, but that was a few iCUE versions ago. It would loose the connection on wake from sleep. A quick re-plug of the USB dongle was the fastest resolution and the problem went away and has not returned.

Which iCUE version are you using? Is there anything in particular that is triggering it? Or does it randomly drop while in use?
Reply With Quote


  #3  
Old 07-19-2019, 11:34 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 104
POST ID # = 1011853
Syberon Reputation: 12
Default

Quote:
Originally Posted by c-attack View Post
I had a short bout with this when it first came out, but that was a few iCUE versions ago. It would loose the connection on wake from sleep. A quick re-plug of the USB dongle was the fastest resolution and the problem went away and has not returned.

Which iCUE version are you using? Is there anything in particular that is triggering it? Or does it randomly drop while in use?
I also have this problem some time - my Ironclaw Wireless doesn't wake from sleep then PC wakes from sleep mode. Turning switch to "off - on" doesn't resolve this problem.

The resolution is to:
1. replug USB dongle
2. set PC to sleep mode again and wake it up

After re out of sleep mode the mouse starts to work. The problem only occurs then PC wakes from sleep. When mouse normally wakes it doesn't disconnects or other problems.

This problem occurs quite often. I'm using last versions of iCUE and firmware.

Last edited by Syberon; 07-19-2019 at 11:38 PM.
Reply With Quote


  #4  
Old 07-20-2019, 06:12 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 8,767
POST ID # = 1011869
c-attack c-attack Reputation: 104
Default

The wake from sleep problem was my issue as well and it was pretty much every single time. Went on for two weeks, stopped, and has never happened again. I don’t think I changed iCUE versions at that time, so I wonder if it is a Windows issue. I am on 1903 now and was then, but something clearly changed.
Reply With Quote


  #5  
Old 07-29-2019, 12:48 AM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 104
POST ID # = 1012939
Syberon Reputation: 12
Default

Quote:
Originally Posted by c-attack View Post
The wake from sleep problem was my issue as well and it was pretty much every single time. Went on for two weeks, stopped, and has never happened again. I don’t think I changed iCUE versions at that time, so I wonder if it is a Windows issue. I am on 1903 now and was then, but something clearly changed.
I have Windows 1903 and this issue is still occur. I think that problem is in dongle because switching mouse to "on - off - on" doesn't helps. Only replugging of dongle or set pc to sleep mode and wake it up again helps. I tried to use dongle with different USB ports (USB 2.0/3.0/3.1 what provided by different controllers on motherboard) but it doesn't helped.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.