The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-13-2019, 09:18 AM
NOR_ec NOR_ec is offline
Registered User
NOR_ec's PC Specs
 
Join Date: Aug 2019
Posts: 3
POST ID # = 1014534
NOR_ec Reputation: 10
Angry Don't know if the Green LED is dead or just a program issue

I have the K95 Platinum RGB for less then half a year and have some issues with
the lighting.
The ESC button and the numbers 2 to 8 don't look like they use the green LED.
Is this because they are dead or just a program bug?
Any advice what to do?
This is not working for like 3 days now.
The second image (DSC_0179) is showing that I am lighting the 4 key with green and all other keys that "can't" show green light up.
Attached Images
File Type: jpg DSC_0178.JPG (4.90 MB, 28 views)
File Type: jpg DSC_0179.JPG (4.35 MB, 23 views)
Reply With Quote


  #2  
Old 08-13-2019, 04:28 PM
Krokarn Krokarn is offline
Registered User
Krokarn's PC Specs
 
Join Date: Aug 2015
Location: Sweden
Posts: 207
POST ID # = 1014576
Krokarn Reputation: 10
Default

How does it look like in the software iCUE? Show us a Picture of iCUE on your screen.
Reply With Quote


  #3  
Old 08-13-2019, 04:51 PM
NOR_ec NOR_ec is offline
Registered User
NOR_ec's PC Specs
 
Join Date: Aug 2019
Posts: 3
POST ID # = 1014577
NOR_ec Reputation: 10
Default

I received a reply from Corsair today and performed what they asked me to do.
I didn't change anything. Same problem.
Here are the pictures with the iCUE.
Attached Images
File Type: jpg DSC_0181.JPG (4.52 MB, 11 views)
File Type: jpg DSC_0182.JPG (3.54 MB, 10 views)
Reply With Quote


  #4  
Old 08-17-2019, 09:24 AM
Xyphus Xyphus is offline
Registered User
Xyphus's PC Specs
 
Join Date: Jul 2018
Posts: 1
POST ID # = 1014926
Xyphus Reputation: 10
Default LED problem with K95 RGB Platinum

As of this morning, I am having the exact same problem with my keyboard. (K95 RGB Platinum) where the ESC and 2-8 keys remain a different color, even after resetting the keyboard (exit iQUE, unplug keyboard cables, hold down ESC and then plug back in keeping ESC pressed for 20 seconds). I have tried resetting my profiles, loading default profiles, etc. Still no luck.

I have iQUE set with a static white on all keys, but the ESC and 2-8 are red, even though they show as white in iQUE.

Did you ever find a solution? Or are LEDs dead on the keyboard?
Attached Images
File Type: jpg k95 rgb image 1.jpg (4.77 MB, 17 views)
File Type: jpg icue static white.jpg (485.3 KB, 14 views)
Reply With Quote


  #5  
Old 08-18-2019, 01:27 PM
NOR_ec NOR_ec is offline
Registered User
NOR_ec's PC Specs
 
Join Date: Aug 2019
Posts: 3
POST ID # = 1015019
NOR_ec Reputation: 10
Default

Sorry for the delay Xyphus, was working.

I still have the problem with the keys.
But I can see that you have red lights on on the keys that are not working properly while I have purple colors.
Go try asking Corsair for a hard reset if you didn't do it already.
Then if you can notify me/us. :D

Here is the picture of the all white keys (if I didn't post it already).
Attached Images
File Type: jpg DSC_0174.JPG (4.32 MB, 12 views)
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.