The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-04-2018, 12:50 PM
Sir_Puppy Sir_Puppy is offline
Registered User
 
Join Date: Aug 2018
Posts: 13
POST ID # = 971449
Sir_Puppy Reputation: 10
Default 150i pro rgb pump noise

Hello guys!
i think my pump does too much noise in quiet mode too.
It's like a tic tic tic tic more fast obv.
Video here:
There is more noise respect to the video.
I can hear it with closed case at a distance of 50cm in quiet mode
Reply With Quote


  #2  
Old 09-04-2018, 10:23 PM
jayhall0315 jayhall0315 is offline
Registered User
jayhall0315's PC Specs
 
Join Date: Aug 2018
Location: San Fran Bay Area
Posts: 21
POST ID # = 971532
jayhall0315 Reputation: 27
Default

Having some experience with custom water loops and the Laing D5s and DDCs (355s), that sounds like an obstruction. I am not sure if Corsair allows the consumer to dismantle the unit and clear it and then refill, but if so, you might try. Otherwise, likely a warranty case.

(Occasionally the capacitor is also faulty and you hear that click sound as well - also a warranty case for 99% of users)
Reply With Quote


  #3  
Old 09-05-2018, 12:34 PM
Sir_Puppy Sir_Puppy is offline
Registered User
 
Join Date: Aug 2018
Posts: 13
POST ID # = 971615
Sir_Puppy Reputation: 10
Default

Ok, i've done a substitution order on amazon.
Reply With Quote


  #4  
Old 09-06-2018, 05:21 PM
Sir_Puppy Sir_Puppy is offline
Registered User
 
Join Date: Aug 2018
Posts: 13
POST ID # = 971750
Sir_Puppy Reputation: 10
Default

it seems better. But there is always a low buzzing sound. I think it's normal. Or not?
Reply With Quote


  #5  
Old 09-07-2018, 06:03 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 8,790
POST ID # = 971797
c-attack c-attack Reputation: 104
Default

There is always going to be some detectable “electric hum”. It’s a high speed mechanical device. On the Quiet 1100 or Balanced 2160 speeds, you should basically have to stick your head in the case to hear it. If you can clearly hear it through the box and over low idle fan speeds, then that would be irritating. However, you will need to figure out if this is really a bad pump or is there something about your set up that is enhancing the effect (close proximity, open mesh, loose motherboard, zero fan speed, etc).
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.