The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-19-2019, 08:12 AM
wapiti59 wapiti59 is offline
Registered User
 
Join Date: Jul 2019
Posts: 2
POST ID # = 1011776
wapiti59 Reputation: 10
Exclamation K70 not detected in iCue

Hi! I have a K70 keyboard that is running through an ioGear KVM switch. I installed the iCue software, but it does not see the keyboard - says No Devices Detected. None of the media keys work at all, just basic keyboard functions. I have tried all of the bios settings positions on the back. The only one that allows the keyboard to function normally is the bypass setting. All the others lock up the iCue software, and the only thing that will work in the other positions is the media keys. HELP???

Last edited by wapiti59; 07-19-2019 at 09:22 AM.
Reply With Quote


  #2  
Old 07-19-2019, 04:15 PM
xatzakos xatzakos is offline
Registered User
 
Join Date: Jul 2019
Posts: 1
POST ID # = 1011830
xatzakos Reputation: 10
Default

Same problem here ...... i think its not detectable Is it ? if yes how ...
Reply With Quote


  #3  
Old 07-19-2019, 05:14 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 551
POST ID # = 1011835
Apophis3 Reputation: 12
Default

For initial setup I would direct connect the unit so iCUE sets up properly, it has to load drivers. Then try the switch.
Reply With Quote


  #4  
Old 07-19-2019, 08:20 PM
wapiti59 wapiti59 is offline
Registered User
 
Join Date: Jul 2019
Posts: 2
POST ID # = 1011846
wapiti59 Reputation: 10
Default

Not a bad thought actually - Thanks!
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.