The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-03-2016, 05:15 AM
juul juul is offline
Registered User
 
Join Date: Jun 2016
Posts: 3
POST ID # = 856131
juul Reputation: 10
Default Corsair VOID wireless - not charging

I just got the headset and I cant seem to get it charging.. In the manual it says it will pulse in a colour associated with the battery status (even when off)... it does no such thing.. if i turn it on while plugged in it will show solid green but as soon as I remove the charging cable it startes to glow red.. its been "charging" for 6 hours now still goes red as soon as i remove the cable and while turned off it has no indication of being charged or what level of battery its currently at..

Can anyone help?

Last edited by juul; 06-03-2016 at 05:19 AM.
Reply With Quote


  #2  
Old 06-03-2016, 06:45 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 856145
Toasted Toasted Reputation: 108
Default

You can get an approximation of the battery charge in CUE by going to Settings>Devices and turning the headset on.
Reply With Quote


  #3  
Old 06-03-2016, 07:33 AM
juul juul is offline
Registered User
 
Join Date: Jun 2016
Posts: 3
POST ID # = 856171
juul Reputation: 10
Default

it just says "?" under battery.. and under status it says "malfunction.. what the hell do I do now?
Reply With Quote


  #4  
Old 06-03-2016, 07:54 AM
juul juul is offline
Registered User
 
Join Date: Jun 2016
Posts: 3
POST ID # = 856176
juul Reputation: 10
Default

okay... force update firmware seemed to work for the most part... its now charging and got to fully charged almost right away.. its still not pulsing colours according to battery lvl though
Reply With Quote


  #5  
Old 06-04-2016, 10:03 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 856372
Toasted Toasted Reputation: 108
Default

If the headset is working fine, i wouldn't worry about the charging indicator leds.

If you want, try a different charging cable (microUSB) and USB port and see whether that changes how the charging indicator led behaves. Though if it was something firmware related, i doubt it will affect it.
Reply With Quote


  #6  
Old 06-08-2016, 05:21 PM
atleeit atleeit is offline
Registered User
atleeit's PC Specs
 
Join Date: Jun 2016
Posts: 4
POST ID # = 857171
atleeit Reputation: 10
Default

I have to jump on board here with similar issues.

I can use the Corsair Wireless plugged in via USB. Audio, Headphones are awesome. I have updated the firmware to the latest 38.01, I have even tried forcing firmware update to 38.01 again. After the update the headset blinks red to indicate charging then after a while it blinks different colours. Then I thought hey it's charged.

As soon as I unplug the device from the USB, it doesn't turn on. then it doesn't go back to charging either. I can force firmware again then it starts charging and blinking red.

Is there another firmware I can test? Or do I have a faulty headset that needs returning? Just bought it few days ago. I purchased the wireless version thinking not having to have wires would be pretty convenient.
Reply With Quote


  #7  
Old 06-09-2016, 08:17 PM
atleeit atleeit is offline
Registered User
atleeit's PC Specs
 
Join Date: Jun 2016
Posts: 4
POST ID # = 857357
atleeit Reputation: 10
Default

I paid $159 AUD for this headset + delivery. I need support to fix this headset. It would be a waste of $20+ to send back and get a replacement.
Reply With Quote


  #8  
Old 06-10-2016, 04:47 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 857419
Toasted Toasted Reputation: 108
Default

Sounds like a faulty headset.

You can request an RMA to replace the headset via Corsair.
https://corsair.secure.force.com/

Note: As it is less than 30 days old, you may be eligible for a prepaid shipping label. You will need to contact customer service via phone to request it. You can call customer service using Skype by using their toll-free number.
Reply With Quote


  #9  
Old 08-04-2019, 03:54 AM
Cblev Cblev is offline
Registered User
 
Join Date: Aug 2019
Posts: 2
POST ID # = 1013647
Cblev Reputation: 10
Default

Quote:
Originally Posted by atleeit View Post
I have to jump on board here with similar issues.

I can use the Corsair Wireless plugged in via USB. Audio, Headphones are awesome. I have updated the firmware to the latest 38.01, I have even tried forcing firmware update to 38.01 again. After the update the headset blinks red to indicate charging then after a while it blinks different colours. Then I thought hey it's charged.

As soon as I unplug the device from the USB, it doesn't turn on. then it doesn't go back to charging either. I can force firmware again then it starts charging and blinking red.

Is there another firmware I can test? Or do I have a faulty headset that needs returning? Just bought it few days ago. I purchased the wireless version thinking not having to have wires would be pretty convenient.
Same here. Did you ever get this fixed?
Reply With Quote


Reply

Tags
help please, question

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.