The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 03-25-2018, 09:50 PM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 946534
loganx1121 Reputation: 10
Default Before my head explodes, does anyone have any ideas?

So a little over a year ago I bought a k95 RGB...loved it. About a month after I bought it, the keys started to change color on their own.

The Platinum came out, so I got that, thinking I wouldn't have the same issue...that was about 8 months ago. Still had the same issue. After about 8 months of clicking on and off the "Advanced" button in the CUE to get my colors to reset back to the way I had them, I finally got tired and submitted a ticket to Corsair support.

If anyone cares the ticket number is 701464.

They told me to hard reset the firmware, which I did, and within 10 minutes 2 keys changed on their own. I reset it again, issue still persisted. They told me to send proof of purchase for the RMA which I did.

I have since updated my ticket several times. I went to Best Buy last night and purchased a new k95 RGB platinum. Thinking that, it's been 8 months, so the manufacturing batch can't possibly be the same...maybe this one will work. Same issue.

Here's a general synopsis:

I've tried both platinum keyboards on 2 different computers, one of which I just built in December. The issue persists.

Because I tend to install the same third party programs on all my systems, and the issue was persistent on both desktops, I tried it on my laptop. I wiped the laptop clean, installed Windows, Windows updates, the CUE and plugged the keyboard in. Issue was persistent on a fresh Windows install with both keyboards.

I made an exception in my antivirus for the CUE folder..grasping at straws. Issue persisted.

I went into device manager, found the "Corsair composite virtual device" and edited the power settings to not allow the computer to turn off the device to save power. The issue persisted.

I changed the USB settings in my power plan via control panel to do the same. The issue persisted.

I exported and submitted to the support team, the CUE logs. They didn't really tell me anything.

I ran procmon on both desktops, filtered by cue.exe process, waited for the keys to change and examined the log. Didn't really find much except a bunch of "no such name" and "file not found" errors related to runtime broker and CUE. I exported these logs to .csv, saved xlsx, and submitted them to corsair support.

I noticed in procmon that the CUE kept writing to and closing some sort of config file. I thought maybe there was some access issue or error doing this that was causing a malfunction, so I ran the CUE on all 3 systems as admin...issue persisted on all 3 systems.

From what I gather, the issue seems to happen somewhat periodically, inside a 2 hour window. As of writing this, the key colors have changed on their own 3 times within 20 minutes. Usually it's not that fast...more like once within 2 hours.

I've confirmed that the keyboard that I've recently purchased and the one I hard reset per tech support's suggestion are running the same firmware revision.

I can take this most recent one back to Best Buy and exchange it for another, but again...3 keyboards in the last year and a half all have the same issue. A fresh Windows install still shows the symptoms, and I have a hard time believing that all 3 of these keyboards just so happen to be purchased by me, and just so happen to have faulty firmware. The odds just aren't in favor of that.

I've tried all the usual solutions I found online, like clearing the on-board storage, remaking the profile, deleting all the profiles and starting over, reinstalling CUE more times than I care to remember, etc.

TL:DR Help...

Last edited by loganx1121; 03-25-2018 at 10:01 PM.
Reply With Quote


  #2  
Old 03-29-2018, 03:27 AM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 947393
loganx1121 Reputation: 10
Default

Well I've tried every version of software available at the link given to me by support

http://forum.corsair.com/v3/showthread.php?t=138472

Issue still persists on both platinum keyboards.
Reply With Quote


  #3  
Old 03-29-2018, 03:55 AM
xMacias xMacias is offline
Registered User
 
Join Date: Feb 2018
Posts: 335
POST ID # = 947399
xMacias Reputation: 20
Default

Can you describe more of how the keys change color on their own? Maybe a video? I'd hate to think it was an unlucky two keyboards, but it may be so you could also try an RMA.
Reply With Quote


  #4  
Old 03-29-2018, 07:33 AM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 947431
loganx1121 Reputation: 10
Default

It's three unlucky keyboards...My original k95 RGB (non platinum) does the same thing.

the key changes seem to be random. What I've seen so far is S, \, Enter, the macro keys on the left, the up arrow key.

It does seem to be random, as sometimes the numpad keys will change, or the left shift key. The most common is the up arrow key and the macro keys. Typically when the macro keys change it's every other one. So G1 changes on it's own, G2 stays white, G3 changes, G$ stays white, G5 changes. The \ and Enter keys are also fairly common.

Sometimes it's just one key that changes, other times all the aforementioned keys are changed.
Reply With Quote


  #5  
Old 03-29-2018, 10:59 AM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 947485
loganx1121 Reputation: 10
Default

Seems like the longer I go without resetting it, the more the colors change. One key changed about an hour ago, now 2 more have changed color
Reply With Quote


  #6  
Old 03-29-2018, 12:35 PM
xMacias xMacias is offline
Registered User
 
Join Date: Feb 2018
Posts: 335
POST ID # = 947501
xMacias Reputation: 20
Default

I'm assuming your keys are set to white and the colors of the LED's don't stay white? And your CUE Lighting is set to static white lighting as well. If that's it, you could try an RMA :s
Reply With Quote


  #7  
Old 03-29-2018, 03:44 PM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 947536
loganx1121 Reputation: 10
Default

I feel like I've already "RMA'd" as I've bought 2 platinums after the initial k95 had this problem.

And only the macro keys, WASD, and arrow keys are white, the rest are set to pulse red.
Reply With Quote


  #8  
Old 03-29-2018, 09:31 PM
datsyuk datsyuk is offline
Registered User
 
Join Date: May 2017
Posts: 32
POST ID # = 947588
datsyuk Reputation: 20
Default

http://forum.corsair.com/v3/showthread.php?t=176156

Is the issue like this? Or something different?
Reply With Quote


  #9  
Old 04-03-2018, 05:37 AM
loganx1121 loganx1121 is offline
Registered User
 
Join Date: Mar 2018
Posts: 6
POST ID # = 948383
loganx1121 Reputation: 10
Default

Different. The new iCUE software seems to have fixed it for me
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.