The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Notices

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-05-2019, 05:55 AM
ForTheRepublic ForTheRepublic is offline
Registered User
ForTheRepublic's PC Specs
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1020300
ForTheRepublic Reputation: 10
Angry Forced to Repair Windows / System Restore after the latest iCUE software update!

As the title states, if I update to the latest version of the iCUE software, the most recent update (3.20.80 I guess), I can't boot into Windows (I'm running Windows 10 64 bit), I'm forced into Windows Recovery troubleshooting/repair, and I have to use System Restore to roll back before the iCUE update! I attempted to update the software a second time after the first attempt resulted in my PC being unable to boot into the OS, in the event that something went awry during the first installation for whatever reason, but it's the same outcome.

And after performing System Restore, the iCUE software no longer detects any of my devices (Corsair Commander Pro fan controller, Lightning Node Pro, and K70 RGB mechanical keyboard). I noticed that this problem became resolved in my second attempt to update the software, because all of my devices showed back up, so the update appears to go just fine until I reboot my PC. This means I can't even just keep running an older version of iCUE, which just adds insult to injury.

I'm currently using iCUE version 3.19.120 and I have never experienced this issue with the software after any of the prior updates until now (been running since June or July I believe). I also have Corsair LINK installed, but it's already running the latest version (4.9.9.3). Windows update just recently installed some beefy updates the same day that the iCUE update rolled out, so I thought maybe the Windows updates could be to blame, but nope, I'm currently fully updated in Windows and able to reboot just fine; it's only the iCUE software update that stops my PC from booting.

This is beyond frustrating. Has anyone else experienced this, or have any idea what the problem could be? Perhaps a software conflict of some sort. The only thing I can think of of is HWinfo64, but I did not have that running during either instance that I attempted updating iCUE.
Reply With Quote
 

Tags
boot issue, boot up problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.