The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-13-2018, 02:54 PM
Phenomenal_Ozzy Phenomenal_Ozzy is offline
Registered User
 
Join Date: Jun 2018
Posts: 1
POST ID # = 958946
Phenomenal_Ozzy Reputation: 10
Exclamation Keyboard on, but not detected?

So I got the k68 and started using it just fine, but after a while it just stopped working. When I restart my PC, it says keyboard not detected, yet my keyboard is connected and the lights are lit. It started to [I]wave flash.[I] I don't know what that means, but can anyone help me with this.
Reply With Quote


  #2  
Old 06-13-2018, 04:54 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 911
POST ID # = 958971
Corsair Nick Reputation: 39
Default

Which OS are you using for your PC? Have you tried plugging into a different USB port stack on the back of the motherboard?

You can try soft resetting the keyboard by unplugging it, hold ESC, plug the keyboard back in, then release the ESC key after 5secs. The keyboard should blink and work normally.
Reply With Quote


  #3  
Old 07-03-2018, 07:20 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961918
Norman24 Reputation: 10
Default

[QUOTE=Phenomenal_Ozzy;958946]So I got the k68 and started using it just fine, but after a while it just stopped working. When I restart my PC, it says keyboard not detected, yet my keyboard is connected and the lights are lit. It started to [I]wave flash.[I] I don't know what that means, but can anyone help me with this.

I'm having the same issue, (K68) yes I tried different USB ports with same outcome..

Last edited by Norman24; 07-03-2018 at 07:31 AM.
Reply With Quote


  #4  
Old 07-03-2018, 07:24 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961920
Norman24 Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
Which OS are you using for your PC? Have you tried plugging into a different USB port stack on the back of the motherboard?

You can try soft resetting the keyboard by unplugging it, hold ESC, plug the keyboard back in, then release the ESC key after 5secs. The keyboard should blink and work normally.
I tried it but still the same outcome... The keyboard is lit but not registering in the iCUE program, therefore I cannot load my defaults..

Last edited by Norman24; 07-03-2018 at 07:36 AM.
Reply With Quote


  #5  
Old 07-03-2018, 09:06 AM
Norman24 Norman24 is offline
Registered User
Norman24's PC Specs
 
Join Date: Jun 2018
Posts: 4
POST ID # = 961928
Norman24 Reputation: 10
Default

Well, I downloaded the iCUE software again and reinstalled it, all is well again...
Reply With Quote


  #6  
Old 06-25-2019, 12:23 PM
sunss sunss is offline
Registered User
 
Join Date: Jun 2019
Posts: 1
POST ID # = 1009287
sunss Reputation: 10
Default

hi my k68corsair keyboard is not working ,its lights arent on it is plugged in and it is not detected by i CUE. i have tried to do a soft reset and i tried different usb ports . i went to use my computer and everything was responsive but my keyboard.
Reply With Quote


  #7  
Old 09-17-2019, 11:43 PM
pro_user pro_user is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
POST ID # = 1018518
pro_user Reputation: 10
Default

K68 user here. Exact same issue happening for me. None of the posted solutions address the issue across any of my computers.

To be clear, k68 lights up red, but no keypresses whatsoever are recognized by any connected PC. ESC-soft-reset fails completely. K68 has become unusable, after just 2 months of ownership. ICUE fails to recognize it.
Reply With Quote


  #8  
Old 09-19-2019, 09:25 AM
Crypton Crypton is offline
Registered User
Crypton's PC Specs
 
Join Date: Sep 2019
Location: USA
Posts: 2
POST ID # = 1018680
Crypton Reputation: 10
Default

Quote:
Originally Posted by pro_user View Post
K68 user here. Exact same issue happening for me. None of the posted solutions address the issue across any of my computers.

To be clear, k68 lights up red, but no keypresses whatsoever are recognized by any connected PC. ESC-soft-reset fails completely. K68 has become unusable, after just 2 months of ownership. ICUE fails to recognize it.
Been having this same exact issue with the K70. Just posted about it here: https://forum.corsair.com/forums/sho...d.php?t=185077
Reply With Quote


Reply

Tags
k68, keyboard

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.