The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-20-2017, 02:49 PM
HellJumper SK HellJumper SK is offline
Registered User
 
Join Date: May 2017
Posts: 2
POST ID # = 904101
HellJumper SK Reputation: 10
Default Volume wheel down freezing keyboard

Received my K95 Platinum yesterday, really liking it so far.

One thing I noticed was occasionally when turning the volume wheel downwards to lower the volume, the volume will continue to lower on its own, all the way down to zero. When this happens, the RGB pattern stays still, and is still illuminated, and the entire keyboard stops working (can't type anything). I have unplugged the USB a few times, after plugging back in it starts working.

It is extremely hard to replicate, I tried to keep scrolling the wheel down, sometimes I got it to freeze.

The wheel itself seems normal, not catching on anything, the scroll is smooth. I tried to spin the wheel lots when CUE was not open, it has not frozen yet.

Has anyone heard of something like this? Does this sound like a defective keyboard? Or bad software? Thanks in advance
Reply With Quote


  #2  
Old 05-20-2017, 06:26 PM
HellJumper SK HellJumper SK is offline
Registered User
 
Join Date: May 2017
Posts: 2
POST ID # = 904122
HellJumper SK Reputation: 10
Default

Forgot to add, I am running CUE 2.13.80
Reply With Quote


  #3  
Old 03-12-2018, 10:40 PM
seisan300 seisan300 is offline
Registered User
 
Join Date: Mar 2018
Posts: 7
POST ID # = 944556
seisan300 Reputation: 10
Default

Hey there, I am new to this fourm and I just registered in it to reply this message.

I know it's an old topic but this kind of freezing started to happend to my K95 RGB Platinum few weeks ago.

As you stated it is hard to replicate and it happens to my keyboard all of a sudden: sometimes I'm just browsing the web, sometimes I'm running a game (where it kind of gets the most frustrating). It just suddenly freezes, the lights keep on and I cannot type anything. Un-plug and re-plug worked, but there was a time when even replugging the keyboard in the same USB port (3.0 or 2.0 no matter which I choose) didn't work until I managed to reset to factory settings.

I've tried so far reseting to the factory sttings by holding the ESC key when I re-plug the keyboard. But so far I've done that about a dozen of times without succesfully fix it.

I tried the force firmware upgrade thing too but nothing either.

I bought the Keyboard since November 2017. I've got it for almost four months now.

I was on the latest CUE 2.23.40 version when the issue started. I now reverted back to version 2.16.87. But hey! the freezing thing even happened to the keyboard when I just had uninstalled the newest version and was about to install the previous one, I mean nothing, no CUE was installed when it froze TWICE in a row.

I was using the CUE on advance mode. Now I'm on the default one.

I'm starting to think it's a defective keyboard. So disapointing for a product which claims to be the top of the line.
Reply With Quote


  #4  
Old 03-12-2018, 11:58 PM
seisan300 seisan300 is offline
Registered User
 
Join Date: Mar 2018
Posts: 7
POST ID # = 944573
seisan300 Reputation: 10
Default

You know what I just realised?

After a time passed since I reinstalled the older CUE Version and all seemed to be fine with my Keyboard, and I forgot connect my ST100 Stand back. After I did, I noticed in the CUE the ST100 it's not being detected even when the lights are by default in rainbow mode and I can connect succesfuly my Void Wireless Headset on it.
Reply With Quote


  #5  
Old 03-13-2018, 12:24 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 1,230
POST ID # = 944672
Corsair Nick Reputation: 39
Default

Try connecting the ST100 to a different USB 3.0 port stack on the back of the motherboard, preferable one with an Intel controller.
Reply With Quote


  #6  
Old 03-13-2018, 12:36 PM
seisan300 seisan300 is offline
Registered User
 
Join Date: Mar 2018
Posts: 7
POST ID # = 944675
seisan300 Reputation: 10
Default

I did with CUE version 2.16.87 and nothing happened. However I made it worked back when I upgraded again to latest version 2.23.40. I now can visualize the ST100 in the CUE and custom its lights as usual.

I Returned to the newest CUE version since the freezing happened to my keyboard again in the previous one. It didn't seem to matter if the K95 was connected in a 3.0 or 2.0 port directly to the MOBO's ports.

I'm trying now connecting it into a PCI-E powered USP 3.0 HUB according to this post: http://forum.corsair.com/v3/showthread.php?t=138820

I wonder how long it'll last until K95 freezes again. Seriously, I would like to know if this problem has been adressed as that post is from 2015. Otherwise I would just like to know why so many users are experiencing this problem.
Reply With Quote


  #7  
Old 03-19-2018, 01:07 PM
jperaino24 jperaino24 is offline
Registered User
 
Join Date: Mar 2018
Posts: 1
POST ID # = 945508
jperaino24 Reputation: 10
Default

I have a new K95 platinum running the latest CUE version and every time I adjust the volume it crashes the Windows Lock Key as well as the Light Brightness Key.
Reply With Quote


  #8  
Old 03-19-2018, 01:48 PM
Bury Tomorrow Bury Tomorrow is offline
Registered User
Bury Tomorrow's PC Specs
 
Join Date: Mar 2018
Posts: 5
POST ID # = 945520
Bury Tomorrow Reputation: 10
Default

We discussed the same issue on this thread recently:

http://forum.corsair.com/v3/showthread.php?t=175837

As far as we're concerned, this seems as a CUE related issue - as killing the process and restarting it restores normal and expected behaviour (and of course using the volume slider instantly locks those keys out of use).

As I am doing so now, I strongly encourage anyone facing this exact same issue to let Corsair know of this by submitting a ticket on support.corsair.com (or using the support ticket system at the top of this page).
Reply With Quote


  #9  
Old 03-19-2018, 08:10 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 1,230
POST ID # = 945572
Corsair Nick Reputation: 39
Default

We are aware of this issue, and have provided more issue in the following thread.

http://forum.corsair.com/v3/showthread.php?t=175898

Last edited by Corsair Nick; 03-19-2018 at 09:19 PM.
Reply With Quote


  #10  
Old 08-11-2019, 05:39 AM
EMJzero EMJzero is offline
Registered User
EMJzero's PC Specs
 
Join Date: Aug 2019
Posts: 1
POST ID # = 1014332
EMJzero Reputation: 10
Default Volume wheel freezing on scrolling down or up

I know this is an old thread, but is the only one talking about my issue i could find...i bought a month ago a K95 RGB platinum from amazon, and despite the fact that it came with a slightly lifted backplate that i fixed was fine, but when i got used to it and had the chance to scroll the volume wheen for maybe more than a 360, it became stuck and kept raising the volume. I had to unplug the keyboard and plug it back, but whenever the wheel is scrolled too far it still happens...i'm on the firmware 3.21.7168, i just made the update but the problem persists! HELP!
Reply With Quote


  #11  
Old 09-09-2019, 02:20 PM
Mobidic Mobidic is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
POST ID # = 1017525
Mobidic Reputation: 10
Default

I have a similar issue than described below. If I use the scroll volume the system may start to push up or down the volume indefinitely and the rest of the keyboard is not responding. Only workaround found is to disconnect the keyboard and reconnect.

Corsair support asked me to install a new firmwave via a drive that shows up when connecting the keyboard with a pin in the back keyboard pressed but that didn't resolve the issue.

Quote:
Originally Posted by EMJzero View Post
I know this is an old thread, but is the only one talking about my issue i could find...i bought a month ago a K95 RGB platinum from amazon, and despite the fact that it came with a slightly lifted backplate that i fixed was fine, but when i got used to it and had the chance to scroll the volume wheen for maybe more than a 360, it became stuck and kept raising the volume. I had to unplug the keyboard and plug it back, but whenever the wheel is scrolled too far it still happens...i'm on the firmware 3.21.7168, i just made the update but the problem persists! HELP!
Reply With Quote


  #12  
Old 08-08-2020, 08:14 AM
Red_Fox Red_Fox is offline
Registered User
Red_Fox's PC Specs
 
Join Date: Apr 2019
Posts: 2
POST ID # = 1056873
Red_Fox Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
We are aware of this issue, and have provided more issue in the following thread.

http://forum.corsair.com/v3/showthread.php?t=175898
hey! when the fix will come?
Reply With Quote


  #13  
Old 08-14-2020, 11:35 AM
nightreignz nightreignz is offline
Registered User
 
Join Date: Feb 2020
Posts: 7
POST ID # = 1057629
nightreignz Reputation: 10
Default

Give us a fix I Paid over $250 CAD for this keyboard and its my SECOND RMA and they all Freeze on the volume wheel.
Reply With Quote


  #14  
Old 10-30-2019, 01:33 PM
Jayavarman5th Jayavarman5th is offline
Registered User
Jayavarman5th's PC Specs
 
Join Date: Sep 2019
Location: Switzerland
Posts: 1
POST ID # = 1022720
Jayavarman5th Reputation: 10
Default

I have this keyboard since around 2 years and still have this problem. I'm quite scared using the volume wheel. By the way, the quality of this keyboard isn't that great. The stands are placed very bad and they break very easily.
Reply With Quote


  #15  
Old 11-03-2019, 12:44 PM
gboy gboy is offline
Registered User
 
Join Date: Oct 2019
Posts: 3
POST ID # = 1022956
gboy Reputation: 10
Default

edit 2: yea sorry, this problem recurred after almost 3 full months of me 'fixing' it. So, I've tested another 'fix' instead. Now, I seem to have great results with setting my polling rate to anything below the maximum (1000hz/1msec) rate. Ive tested the 500hz/2msec polling rate reaaaaaaaally extensively (like 15 minutes of just scrolling the volume wheel up and down). So far 0 freezes. The moment I switch to the max 1000hz/1msec and spam scroll the volume wheel, freeze problem usually recurs within like 30 seconds or less. So, it does seem like polling rate's the issue here. Lets hope it stays that way. Will update all posts if problem recurs.

edit: ok I think this fix works, courtesy of Corsair email support, cant believe nobody has reported on this fix considering how long this problem has been around for:

"Google Chrome has a driver that takes control of our media keys, preventing them from being used with Desktop apps while Chrome is open. To fix this issue:

- Head to ‘Chrome://Flags
- Locate Hardware ‘Media Key Handling’
-From the drop down set to ‘Disable’

If this didn't help please do let us know."

Now, Im spamming the volume wheel up and down like a madman for a couple minutes and so far 0 keyboard freezes. Im gonna try it over a couple weeks to be 100% certain. WIll update if this problem recurs!

Last edited by gboy; 01-30-2020 at 02:05 PM.
Reply With Quote


Reply

Tags
k95 platinum volume wheel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.