The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Power Supplies

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 11-05-2016, 06:53 PM
james3126 james3126 is offline
Registered User
 
Join Date: Nov 2016
Posts: 1
POST ID # = 878103
james3126 Reputation: 10
Angry HX750i creating noticeably loud noises

I have received a brand-new HX750i (previous one had shown white smoke). After installing the PSU into my fairly mediocre PC, I booted it up to hear the most horrible noises being given out. I quickly shut down the PC fearing damage to my components.

After a bit of googling I found that there are a few 'power saving' modes in the BIOS that may be the source for these noises. I did as it said and booted the PC. The PSU gave off the same noise.

I am now unsure of what to do apart from RMA a second HX750i this month.

It is not the PC as the CX750M works a treat, but is being used in another PC right now.

If anyone could help me by pointing out anything I may have missed, give me any troubleshooting tips or tell me that it's not my fault, would be greatly appreciated thanks in advance
Reply With Quote


Reply

Tags
broken, icry, noise, psu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.