The Corsair User Forums  

Go Back   The Corsair User Forums > Customer Service > Warranty and RMA Questions

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-03-2018, 10:27 AM
rdelk rdelk is offline
Registered User
rdelk's PC Specs
 
Join Date: Sep 2018
Posts: 0
POST ID # = 971286
rdelk Reputation: 10
Angry Cannot Access Support Page - "Unknown Error"

I'm at my wit's end trying to complete this RMA for my PSU.

tl;dr:
When I log into support.corsair.com I am greeted with "Error - Unknown Error". See attached image.

The URL of the page is https://support.corsair.com/app/error/17.

Long story:
I cannot access the account under which I purchased the PSU (purchased on Corsair.com), so I created a new account. The old account can still log in, but cannot create a ticket. The new account can log in, but cannot access tickets.

Longer story:
I purchased my PSU through Corsair.com a few months ago (around March/April). I recently built my computer and discovered that the fan in the PSU knocks against the inside of it. I tried creating a support request, but I cannot currently access the email for that account, which is apparently required when creating a ticket.

I called support to ask what I should do, and I was told to create a new account that I did have access to and create the RMA under that account. So I registered a new account under a different email address.

When I went to log in to support again (with my brand new account), I was greeted with the super helpful error message seen in my screenshot.

I called support again to inquire, and the representative said he would create the ticket for me and that I would receive updates through my email. That sounds great, and at this point I was thinking it was something to do with my account being so new.

I check my email and indeed receive my RMA information, but I can't do anything about it because any links or anything that are in the emails require me to log in to the support site, which will only ever give me this error message.

I called support again and spoke with someone for probably an hour trying to troubleshoot. She was very helpful, but we weren't able to figure out the issue, so she said she would follow up and let me know. She even went so far as changing my password to test it on her end, and she saw the same results. It's been over two weeks now and I've still heard nothing back, and she hasn't responded to any of my emails.

Things I've tried:
• Different browsers (my primary browser is Opera, as seen in the screenshot, but I've tried Chrome, Internet Explorer, Edge, and Firefox)
• Clearing browser cache and cookies
• Disabling extensions

Again, my old account can still log in and see the support page, but my new account, the one the ticket is under, brings me to this error page immediately after entering my username and password. I can access all other parts of the site except that page, which is the only one I need to complete my RMA.

I can do some browser debugging and the exceptions I'm encountering have this message:

Code:
"Failed to execute 'querySelectorAll' on 'Element': '*,:x' is not a valid selector."
Attached Images
File Type: png CorsairUnknownError.PNG (78.1 KB, 91 views)
Reply With Quote
 

Tags
error, rma, support, unknown, unknown-error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.