The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-10-2014, 02:52 PM
LAZER LAZER is offline
Registered User
 
Join Date: Sep 2014
Posts: 3
POST ID # = 726667
LAZER Reputation: 10
Default K70 keys repeating/not working

So I bought the K70 Cherry Brown version 4 months ago now and around a month ago my keys started repeating and often taking several presses to work once. I've cleaned this keyboard out thoroughly twice in the past month and it definitely helped to a degree, but ultimately the problem is still here and it's becoming incredibly irritating. I never thought there was any firmware out for the K70 but I've read in a few places there is now and I'm wondering if this could be of use? Hope to get some replies. Thanks!
Reply With Quote


  #2  
Old 09-10-2014, 02:54 PM
Yellowbeard's Avatar
Yellowbeard Yellowbeard is offline
Banned
 
Join Date: Oct 2002
Location: Atlanta,GA, USA.
Posts: 11,531
POST ID # = 726668
Yellowbeard Reputation: 46
Default

If you are not using the most recent firmware, you should definitely update it. Downloads are on the product page and under the Support tab on www.corsair.com
Reply With Quote


  #3  
Old 09-11-2014, 05:22 PM
LAZER LAZER is offline
Registered User
 
Join Date: Sep 2014
Posts: 3
POST ID # = 727124
LAZER Reputation: 10
Default

Installed the latest firmware. Hasn't solved the problem at all. Keys constantly repeating/not working, had it for 4 months.
Reply With Quote


  #4  
Old 09-11-2014, 10:09 PM
Corsair LeChuck Corsair LeChuck is offline
Banned
 
Join Date: Jun 2014
Posts: 57
POST ID # = 727210
Corsair LeChuck Reputation: 10
Default

Please disable USB Selective Suspend temporarily (found in the Advanced Power Settings in Power Options located in Control Panel).

Reboot Machine.

Connect the keyboard to USB 2.0, and apply the firmware update.

If the issue persists please let me know via PM so that I can expedite your issue and have it resolved as soon as possible.
Reply With Quote


  #5  
Old 09-13-2014, 03:49 PM
LAZER LAZER is offline
Registered User
 
Join Date: Sep 2014
Posts: 3
POST ID # = 727644
LAZER Reputation: 10
Default

I can't find this option unfortunately... I'm on XP. Could this be the reason?
Reply With Quote


  #6  
Old 05-23-2019, 02:08 PM
sfinktah sfinktah is offline
Registered User
 
Join Date: May 2019
Posts: 1
POST ID # = 1005477
sfinktah Reputation: 10
Default

K70 - Red; with blue cherry-mx.

I have suffered random occurrences of this, as long as I can remember:


Code:
added some tttttttttttttttttttest anti-crash code
I've never stopped to notice whether this is specifically the `t` key, or any key, but it's always that many repeats.

i.e. i've never had "ttest", "tttest", or "tttest", when it repeats, it goes for broke, feels a bit like the keyboard is rebooting.

I've tried different settings of speed on the back selector, currently it's set on '1' and is still occurring. i have just switched it to bios, which means the scroll-lock led is annoyingly blinking on and off.

i'm not running any special corsair keyboard driver, if I could find one, I would. iCE doesn't recognize my keyboard, just my Void headphones.

trying on another computer isn't really an option, as this (whatever it is) doesn't necessarily occur for days, or it can occur multiple times per day.

it seems to present itself when I'm using Discord, rather than when I'm coding. I'm not sure if this more to do with typing style, or the application.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.