The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 05-08-2019, 07:39 AM
Griff_ Griff_ is offline
Registered User
Griff_'s PC Specs
 
Join Date: Jan 2012
Posts: 8
POST ID # = 1003917
Griff_ Reputation: 10
Default Corsair HS70 firmware/charging issue

Hi all, after a bit of googling i was unable to find any similar issues, so I came here to ask:
I recently bought the corsair HS70, and from the moment i charged it to full (3h) and then turned it on, I was incredibly satisfied with its audio quality, performance, longevity, and quality of life / utility features. Literally could not be happier with my very first wireless headset. However:

perhaps maybe 1/2 weeks after my purchase, I applied another firmware update, and ever since then (not sure if coincidence or not) the "Charge complete" notification is absent.

When I plug the headset in, it will cue "Charging battery". Then at multiple periods throughout its charge it will cue the same, at seemingly random intervals. Then from what i can tell, when its actually at full battery it will cue "Charging battery" twice in a row, I think?

I experience no battery degradation, and the charge seems to take as long now as it did on the second day of use, and similarly can last entire days of usage and still not run out of battery. The only thing thats been niggling at me is this lack of "charge complete" which would prompt me to disconnect the charge cable - essentially turning the headset into a wired headset for the portion of the day where i forget / have no reason to disconnect the USB cable. Similarly, if i leave the cable in and disconnect after 5 hours, the battery level shows at 93% or 90%. However leaving it in for 2 hours~ and removing shows a battery level of 100%? Can't be certain this is true in all cases, I have not had the patience to test extensively.


So I come here to ask you all, has anyone else experienced the same? Using firmware 0.64? And similarly I was unable to find legacy firmware versions, so I've currently been unable to test previous firmware images on the device, which i would very much like in order to rectify this issue. Does anyone know where its possible to obtain previous firmware versions for the device?

Last edited by Griff_; 05-08-2019 at 07:47 AM.
Reply With Quote


  #2  
Old 05-08-2019, 11:34 AM
Corsair Notepad Corsair Notepad is offline
Corsair Employee
Corsair Notepad's PC Specs
 
Join Date: Nov 2018
Location: Fremont, CA
Posts: 265
POST ID # = 1003932
Corsair Notepad Reputation: 10
Default

Try this and see if it resolves your issue.

Press and hold the mute button for 25 seconds.
After releasing the mute button wait 15 seconds.
Now test the headset and see if you are experiencing the same issues.
Reply With Quote


  #3  
Old 05-10-2019, 08:23 AM
Griff_ Griff_ is offline
Registered User
Griff_'s PC Specs
 
Join Date: Jan 2012
Posts: 8
POST ID # = 1004136
Griff_ Reputation: 10
Default

Did as was suggested. Its been plugged in for 4 hours and has still not output "Battery full" even though it took only 3 hours on first charge. Unplugging and checking battery shows 88% even after 4 hours. Similarly its still running 0.64.

What exactly is holding mute supposed to do?
Reply With Quote


  #4  
Old 05-14-2019, 09:02 AM
Griff_ Griff_ is offline
Registered User
Griff_'s PC Specs
 
Join Date: Jan 2012
Posts: 8
POST ID # = 1004536
Griff_ Reputation: 10
Default

After another 4 days of use, it has still failed to provide "Batter Full" notice, when one day i left it plugged in for 6~ hours.
Reply With Quote


  #5  
Old 05-23-2019, 11:58 PM
Criptike's Avatar
Criptike Criptike is offline
Registered User
Criptike's PC Specs
 
Join Date: Mar 2019
Location: Québec
Posts: 4
POST ID # = 1005542
Criptike Reputation: 10
Default

Had the same thing but it doesnt matter, the battery is still full, the software is wrong with the numbers, I just ignored it. But I will have the warning sound after a while, you can disable the warning sound of low battery by deleting the sounds files in the icue folder and after that you can enjoy the full battery of the hs70 o:

For me its about 14hours of battery without interruption :)
Reply With Quote


  #6  
Old 05-24-2019, 05:53 AM
Griff_ Griff_ is offline
Registered User
Griff_'s PC Specs
 
Join Date: Jan 2012
Posts: 8
POST ID # = 1005560
Griff_ Reputation: 10
Default

The issue is not the battery being full or not. The issue is not being informed when it is full, the result is simply the annoyance that i need to turn off the power to the headset and check the power level in the settings manually before turning it back on. The result of which is preferring to leave it plugged in rather than go through that effort, which essentially turns it into a wired headset. I would really like to know if anyone knows where i can find legacy drivers/firmware so i can get the audio cue working again. I really dislike not having the cue and desperately want it back.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.