The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-25-2020, 02:30 PM
deankenny21 deankenny21 is offline
Registered User
 
Join Date: Nov 2017
Posts: 11
POST ID # = 1066892
deankenny21 Reputation: 10
Default Commander Pro causing USB disconnects

Even as I was typing this title I got a disconnect, oh the irony.

Anyway, so I just did my new build and went all out on parts, including corsair QL fans 6 of them all connected to a RGB hub and Commander Pro.
Upon finishing my build I kept getting usb disconnections, they would instantly reconnect, so I started digging and I have found out it is the commander pro.

Upon a google search I see it is a very common problem, especially on X570 Asus Prime boards, which is the board I have. I do see that many have fixed this issue by buying a part from a completely different vendor to correct some sheer laziness from corsair on trying to sort this. A thread started way back in 2018, and multiple threads and literally 1 post from corsair saying we are looking at it, fast forward to end of 2020 here we are with still the very same problem. Never mind the fact icue pegs your cpu voltage to never clock down or sleep, without again some more help from someone else to fix corsairs laziness (1usmus custom Power Plan for Ryzen).

Anyway, so why am I posting this, if I found many posts already on this matter, well I suppose it's a desperate last ditch attempt at getting some help before having to spend £20 just to fix it with an nzxt internal hub.
Has anyone found a fix for this issue at all, simply closing Icue doesn't work for 2 reasons, 1. The commander pro is still connected to the usb network regardless of icue and 2. I need icue running to run my really EXPENSIVE corsair part I spent good money on!

Things I've tried.
Fresh reinstall of windows (it's fresh anyway as it's a new system with all new parts)

Turned off selective usb in power option.

Turned usb power management off in device manager on all connected usb devices.

Gave the commander pro it's own dedicates Sata Power with only it connected to the psu.

Closed Icue

Updated Bios, windows and all other drivers
Reply With Quote


  #2  
Old 10-26-2020, 06:20 PM
Corsair Mint's Avatar
Corsair Mint Corsair Mint is offline
Corsair Employee
 
Join Date: Apr 2016
Posts: 1,193
POST ID # = 1067096
Corsair Mint Reputation: 31
Default

Hey deankenny21,

If you're getting disconnects like this, I'd recommend reaching out to our Support team so they look further into the issue since you've already tried a bunch of troubleshooting steps.
https://help.corsair.com/hc/en-us/requests/new
Reply With Quote


  #3  
Old 10-27-2020, 07:51 AM
Qqu Qqu is offline
Registered User
Qqu's PC Specs
 
Join Date: Jun 2005
Posts: 109
POST ID # = 1067167
Qqu Reputation: 10
Default

Asus released a bios update for my x570 Crosshair viii hero that addresses a keyboard device issue... I dunno what that exactly fixes but perhaps there is an update for your prime board that might be worth looking in to
Reply With Quote


  #4  
Old 10-27-2020, 07:31 PM
curveball323 curveball323 is offline
Registered User
 
Join Date: Oct 2020
Posts: 1
POST ID # = 1067265
curveball323 Reputation: 10
Default

I have the same issue on a Gigabyte Aorus Elite X570 board. I have 6 fans connected and they used to work just fine with the included RGB hub and USB adapter. But since I updated to a Commander Pro to Power all 6 fans. It disconnects every 10 seconds and none of the LED light configurations work other than the solid colors. the preconfigured lights will pause then skip and it looks horrible. All Firmware is updated on the commander pro v.0.9.212 and Icue is running the latest 3.34.170 released today. I can send logs and a video of whats going on if needed let me know.
Reply With Quote


  #5  
Old 10-29-2020, 08:32 AM
deankenny21 deankenny21 is offline
Registered User
 
Join Date: Nov 2017
Posts: 11
POST ID # = 1067460
deankenny21 Reputation: 10
Default

Thanks for all the replies, but I feared they would all be of no help to me.

So I just bit the bullet and spent £20 on an NZXT internal powered usb hub, as that seems to be the "one and only" fix for this ridiculous issue.

I am very surprised that for a product so popular AND reported with the same problem over and over, a google search returns page and pages of this disconnection problem, i am surprised that Corsair have done nothing about it.

I am 35 year old PC Gamer, so I have been brought up through all of the brands ages, brands coming and going, brands failing, brands prospering. But Corsair have always been the old school brand that hasn't gone anywhere and continues to make products of decent quality vs price, so as I said, this has really surprised me and put a massive dent into how I now think about Corsair moving on.

Companies like Lian Li designing the new daisy chained fans only needing 2 cables for a row of 5 fans!!! I think it's time to move on and start to put my trust in these younger brands.

It's a shame really, as I spent £2,900 on my new system and 90% of it is corsair to begin with, but with issues, problems, and just downright annoyance, it's gone down to 50%. I replaced my corsair AIO with an Asus Strix ROG LC 360 cooler and literally plugged it in and worked from day 1 with not 1 issue unlike the corsair aio in there originally.

Put it this way, my system now works better with a complete mix and match of brands for all the different parts than having it ALL corsair, that says it all really.
Reply With Quote


  #6  
Old 10-29-2020, 09:18 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 12,673
POST ID # = 1067465
c-attack c-attack Reputation: 122
Default

Do you really think they should recall and replace every Commander Pro in existence because AMD came out with a MB after the fact that doesn't get along? It's the x570 that has all the issues. Sorry having to buy an inexpensive USB hub ruined your build. Of course, a lot of people end up buying one anyway since their MB only has 1-2 internal USB ports.

When you daisy chain, you are turning the entire string into one long strip. That means forgoing all the individual customizable nature of CUE and the Corsair system. If you just want to them blink or light up and don't really care about what they do, then that may not be so bad. You can't have it both ways.
Reply With Quote


  #7  
Old 10-29-2020, 09:40 AM
deankenny21 deankenny21 is offline
Registered User
 
Join Date: Nov 2017
Posts: 11
POST ID # = 1067470
deankenny21 Reputation: 10
Default

Quote:
Originally Posted by c-attack View Post
Do you really think they should recall and replace every Commander Pro in existence because AMD came out with a MB after the fact that doesn't get along? It's the x570 that has all the issues. Sorry having to buy an inexpensive USB hub ruined your build. Of course, a lot of people end up buying one anyway since their MB only has 1-2 internal USB ports.

When you daisy chain, you are turning the entire string into one long strip. That means forgoing all the individual customizable nature of CUE and the Corsair system. If you just want to them blink or light up and don't really care about what they do, then that may not be so bad. You can't have it both ways.
I think you will find it's the companies responsibility to make it compatible with a chipset, not the chipset responsibility, really think X570 are going to go and find ALL the pieces of hardware available EVER in the whole wide world for PC and go through each piece of hardware one by one and make them work, not on your nelly. Seriously open your mind for a second and just think about that vs the piece of hardware manufacturer just updating drivers/software, cmon now.

I'll tell you how it works, and how it should work, When a new chipset comes out as i'm pretty clued up on this with all my experience you can learn, it is up to the companies like corsair, Lian Li, razer etc etc whoever it may be to then update their drivers and /or software to become compatible, not the other way round, no idea how you come across that belief, that it just beyond absurb and laughable, so wrong!

No idea what your talking about with daisy chaining, more ignorance, as the Lian Li fans is the only thing I mentioned regarding that, and they are very much customisable on a piece to piece level.

Ignorance is not bliss my friend.

Last edited by deankenny21; 10-29-2020 at 09:44 AM.
Reply With Quote


  #8  
Old 10-29-2020, 11:45 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 12,673
POST ID # = 1067488
c-attack c-attack Reputation: 122
Default

Quote:
Originally Posted by deankenny21 View Post
I think you will find it's the companies responsibility to make it compatible with a chipset, not the chipset responsibility, really think X570 are going to go and find ALL the pieces of hardware available EVER in the whole wide world for PC and go through each piece of hardware one by one and make them work, not on your nelly.

Not everyone has even a general sense of business practices, costs, production, and the like. That's OK. However, I wasn't sure if you were aware of the timeline with the Commander Pro having been developed 4 years ago and prior to the launch of the x570. It's not a software fix. You ran right through that without looking and don't seem to care.

There are over 50 Lian Li RGB fans in the room I am currently sitting in. You go right ahead and plug them into your Asus D-RGB header and start programming your complex patterns. Good luck. You've obviously never worked with most other RGB systems.

I do feel bad about people who stumble into the disconnect problem unaware. I don't feel so bad if they continue to remain uninformed and arrogant.

Last edited by c-attack; 10-29-2020 at 12:24 PM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.