The Corsair User Forums  

Go Back   The Corsair User Forums > Customer Service > Warranty and RMA Questions

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-17-2020, 12:08 PM
Vindorkester Vindorkester is offline
Registered User
 
Join Date: Sep 2020
Posts: 0
POST ID # = 1061730
Vindorkester Reputation: 10
Default Awful customer support experience

I bought a PSU that after a short time became defect.

So I started googling the issue and found a Therese where the customer support
wrote as an answer ”Just contact us and we’ll send you a new one”.

So I did just that, contacted corsair hoping to get a new PSU before the one I got stops working at all.

After some days they responded and askes some questions.
I answered.

After another few days It was approved.
But then they wanted me to send my PSU first, but that can’t happen since I work on the PC the PSU is connected to.

So after another few days they said they were going to send a PSU to me first.
I responed.

After another few days they asked for payment.
I answered for what? After a few days they said because they are at risk by sending me the PSU first.
I replied, So I should be at risk? When it’s you who’ve sold me a defect PSU

After Another few days I got an email from ”escalated team” or something.
Escalated? Because I’m wondering why I should pay? Anyway she said exactly what the other guy had said but in one email.

Now I was so tired of this customer support, takes days for answers and they’re not responding to my questions, only like generalised answers

So I pay them the money just so I can get the new PSU atleast. Like $140.

After a few days I got an answer saying they’ve sent the new PSU.
After a week or so I got it.

Now they’ve stopped responding to my messages about a return label for the other PSU so I can get my money back. No answers in a week. So I called them and there was this dude answering and I explained that I need a return label to send the PSU back so I can get my money back. He was like ”it’s not working”
So he redirected me to another dude who I needed to explain everything again. He asked me to hold and then was like ”It’s not working” He said he was going to contact me later, but I doubt it...
I feel kinda scammed

This has taken more then THREE months! I just want my money back... I knew i never should’ve paid..

Sorry for my bad English, it’s not my mothertongue.
Reply With Quote
Reply

Tags
bad customer experience, customer support, payment, rma

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.