View Single Post
  #1  
Old 06-17-2018, 11:23 PM
friendkiller96 friendkiller96 is offline
Registered User
 
Join Date: Jun 2018
Posts: 1
POST ID # = 959554
friendkiller96 Reputation: 10
Default ONLY Corsair devices disconnect / reconnect

Okay, so I'm hoping someone here can help me out here.

I have a Corsair Strafe RGB Keyboard, Corsair Glaive RGB Mouse, And the Void Pro Wireless headset and whenever I launch Fortnite (Haven't tried it with other games) randomly, sometimes it won't even happen, the devices I just mentioned will disconnect and reconnect indefinitely forcing me to restart my computer.

This recently just started happening as well, and I doubt it is an issue on Fortnite's end as users have complained in the past about devices Disconnecting and reconnecting.

I have tried troubleshooting as well, and here is what I have tried.
I moved the hub the devices are connected to, to another port, updated device firmware, updated windows 10 software, updated icue, unplugged and re-plugged back in. All have done nothing. Thing is while I'm on desktop and not in a game it doesn't freak out but only sometimes in game will it disconnect and reconnect.

Things to note: I have the devices plugged into a USB hub.

Here are my computer specs as well as the firmware versions on the devices. Hopping someone can give me some help on this.

Motherboard: MSI Z87-G45
GPU: MSI R9 390X (x2)
Processor: Intel Core i7-4790K @ 4.00 GHZ
RAM: Corsair Vengence 32 GB DDR3
PSU: EVGA 1000W G2
Keyboard Version:2.05
Mouse: 1.04
Headset: 0.15