Thread: ICUE wont open
View Single Post
  #43  
Old 11-16-2019, 06:21 AM
Dpheonix1038 Dpheonix1038 is offline
Registered User
Dpheonix1038's PC Specs
 
Join Date: Nov 2019
Posts: 1
POST ID # = 1024102
Dpheonix1038 Reputation: 10
Thumbs up Bless

Quote:
Originally Posted by JNic View Post
Moving(copying really) the Corsair folder to the Program Files (from Program Files (x86)) directory also worked for me. Here are all of the steps that I did for anyone else.

1. Open Task Manager and end the iCue task if it is running
2. Open Services and stop the CorsairService
3. Copy this entire directory, C:\Program Files (x86)\Corsair, to here, C:\Program Files\Corsair
4. Open the Registry Editor and change the value for Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\CorsairService\ImagePath from C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\Corsair.Service.exe to C:\Program Files\Corsair\CORSAIR iCUE Software\Corsair.Service.exe
5. Open the Properties of this shortcut, C:\ProgramData\Microsoft\Windows\Start Menu\Corsair\iCUE and change the Target from C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\iCUE.exe to C:\Program Files\Corsair\CORSAIR iCUE Software\iCUE.exe and change Start in from C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\iCUE.exe to C:\Program Files\Corsair\CORSAIR iCUE Software\iCUE.exe. Click Apply and OK.
6. Open iCue through that shortcut and it should open. This should also start that CorsairService. But, if it does not then manually start it.

I am still curious why this works. I saw a couple posters above mention Steam and Malwarebytes. I do have both of those installed if it helps anyone figure it out.


Thank you very much for posting this! It has been almost 3 months and NOTHING worked until I followed this!
Reply With Quote