View Single Post
  #1  
Old 12-13-2015, 10:35 AM
Hoffie92 Hoffie92 is offline
Registered User
Hoffie92's PC Specs
 
Join Date: Dec 2015
Posts: 2
POST ID # = 825386
Hoffie92 Reputation: 10
Default Corsair VOID Wireless drivers not recognized

Hello everyone,

I just recently bought a Corsair VOID Wireless SE Yellowjacked and i love it so far, But when i wanted to update the firmware on the headset it just shut down never to come alive again.

I already left it to rest for over 24H to drain the battery, That worked.
But it will not turn on now, Even with the charging cable plugged in. there are also no lights that light up when the headset is plugged in or when I try to turn it on it does nothing, No lights, No Beep. nothing

Windows sees that i plug something in but somehow it does not know what drivers to use for the headset. The USB dongle is recognized properly. But for the headset itself it is named like this: Unknown USB Device (Invalid Device Descriptor), My question now is the following, Is there a place where i can download or find the drivers for the headset myself, So i can assign these to the headset so that windows sees it as my headset.

I already tried re-installing the CUE software multiple times, Even the older versions. CUE also does not recognize the headset as being plugged in via USB port, it keeps telling me to plug in the Headset.

I also made a screenshot with it, Here you can see that it does not recognize my headset (Red circle's) But it DOES recognize my USB dongle (Green Circle).

Thank you in advance.

Greetings from the Netherlands
Danny Hofland
Attached Images
File Type: jpg Broken headset.jpg (1.10 MB, 1065 views)
Reply With Quote