View Single Post
Old 06-20-2018, 03:36 PM
jigar7 jigar7 is offline
Registered User
jigar7's PC Specs
Join Date: Jun 2018
Posts: 5
POST ID # = 960053
jigar7 Reputation: 10
Angry Corsair screwed up!

I have the same issue with my K70 RGB (2014-15 Model)

This started after CUE 2.24.50 prompted me that there is a newer version available which was iCUE 3.3.103. I updated it to iCUE and it all went downhill from there.

After the first reboot, my keyboard started to connect/disconnect continuously until I quit iCUE and put the keyboard in BIOS mode. I could use it in BIOS mode without any lighting effects etc, but I can't, because the keyboard kind of disconnects briefly after every 5-10 minutes, so during an intense gaming session, this is not good. I couldn't care less about CUE since after every update, something or the other breaks.

I removed cue, cleared appdata, cleaned registry, rebooted and downgraded to CUE 2.24.50 but the problem seems to have become permanent unfortunately. Thank you Corsair for the wonderful iCUE 3.3.103 update.

Contacted Corsair support and I was instructed the to do the same s*** again. Repeated it but the problem still persists. Even on reboot, windows refuses to boot unless I disconnect the USB of the K70 (Nope, doesn't even boot up in BIOS mode of the K70)

After a couple days, I tried CUE 2.24.50 again and I tried to check for the update. Guess what, it no longer redirected me to the webpage of iCUE 3.3.103. Instead it showed me 'software up to date'

I'm quite sure Corsair knew they ****** up but are not yet acknowledging the issue. I don't know how this is going to get fixed as my keyboard is out of warranty now. If this doesn't get fix, I know what brand to not go for. I feel cheated. I've been dealing with this issue since the past 2 weeks and I can't find a solution even on Google.

Last edited by jigar7; 06-20-2018 at 03:38 PM.