View Single Post
  #6  
Old 12-06-2019, 04:21 AM
hatman5700 hatman5700 is offline
Registered User
hatman5700's PC Specs
 
Join Date: Dec 2019
Posts: 6
POST ID # = 1026497
hatman5700 Reputation: 10
Default

I believe I mentioned it along the way; but is there any other direct action I can take to try to resolve the Device Manager error with the USB Device: Unknown USB Device (Device Descriptor Request Failed)? <see attached>
  • This is occurring in all scenarios of plugging in the node [plugging in via mini-usb to 9pin header in BOTH headers, plugging in via mini-usb to regular USB in about 4-5 different ports (back, front, 2.0, 3.0, you name it I plugged it and tried)].
  • I've done right click > Update driver > Search automatically for updated driver software > Result: "The best drivers for your device are already installed" --- is there somewhere instead I can manually download or force driver updates?
  • I've also tried right click > Uninstall device > restart > open ICUE > settings > ICUE settings > Restart iCUEService > Result: the device re-appears in my device manager but is still in the same erroneous state: Unknown USB Device (Device Descriptor Request Failed)


Related/Unrelated troubleshooting steps:
Attached Images
File Type: png NoPro DeviceMan Failed.png (45.5 KB, 14 views)
Reply With Quote