View Single Post
  #28  
Old 07-06-2019, 09:40 AM
simon.w simon.w is offline
Registered User
 
Join Date: Jul 2019
Posts: 6
POST ID # = 1010458
simon.w Reputation: 10
Default

Quote:
Originally Posted by ltron View Post
Did you try flashing the K55 keyboard with the older firmware that Corsair gave me? I've linked to it in this post: http://forum.corsair.com/v3/showpost...4&postcount=38

This fixed all my problems.
This actually worked for me too. But then the K55 went into a connect-disconnect-loop in iCUE. I had to manually download an older version of iCUE (you can change the actual link that Corsair provides to a version of your liking) and then it worked. It's not a solution though, because the old firmware + software might get incompatible with future Win10 Updates.

I couldn't fix the issue, Corsair couldn't as well. They said, they would exchange the keyboard if they couldn't fix it, but just closed my ticket and didn't answer anymore. I bought a Logitech keyboard now - which works perfectly fine. I'll have to return the keyboard via Amazon, since Corsair didn't help me.
Reply With Quote