View Single Post
  #19  
Old 06-20-2019, 11:30 AM
Ceramicist Ceramicist is offline
Registered User
Ceramicist's PC Specs
 
Join Date: Jun 2019
Posts: 1
POST ID # = 1008644
Ceramicist Reputation: 10
Default Possible Solution

I ran into this same issue. Upgrading iCue caused a bootloop and an error on the boot device being unavailable. I was able to get back in by using a system restore point, but iCue no longer recognized any of my devices (K95, Void Pro, Scimitar Pro). I redid the upgrade from a direct download (instead of through the utility's update) and had the same issue once again resolved by a system restore.

What I did next appears to have worked just fine.
1) Fully uninstall iCue
2) Reboot
3) Install iCue from a direct download
4) Reboot

I was able to get back in just fine and all of my devices were available. I noted that during the install I was asked to close certain programs so it could install, something I was never asked when it was trying to upgrade a previous install. I don't know if that is the issue: components that don't get fully installed in an update but do in a clean install.
Reply With Quote