View Single Post
  #1  
Old 11-09-2019, 06:19 PM
RBurgundy RBurgundy is offline
Registered User
RBurgundy's PC Specs
 
Join Date: Nov 2019
Posts: 4
POST ID # = 1023495
RBurgundy Reputation: 10
Arrow CMW32GX4M2C3200C16 X570 BSOD / Solved!

Running a Ryzen 7 3700X with a Gigabyte X570 Ultra and 5700XT GPU, 2x 16GB CMW32GX4M2C3200C16 and a 850 Corsair PSU.

Issue is that I can not get my system to run stable when I enable the XMP in BIOS. System runs great at 2133 but as soon as I enable XMP to get the 3200 speed I get random BSOD, sometimes when powering down or when watching YT. MemTest86 shows well over 200 errors after only 2 minutes!

- Did a clean Win install, with latest AMD drivers etc.
- Tried all different memory slots and combinations on the mainboard
- Used 2 another same set of ram sticks
- RMA'd the mainboard and memory
- Tried entering the memory timings by using the Ryzen DRAM calculator (every which way that I found on the www)
- Used the Corsair How-To-Guide for memory overclocking
- Enabled XMP manually set the Multiplier to 32 and Voltage to 1.35V
- Tried the above with High frequency support to Level 1
- Tried it in a number of different variations and suggestions in various forums
- Tried most of the above on BIOS with AGESA 1003 ABBA, AGESA 1004B and AGESA 1004B & SMU 46.54.0

Nothing did result in any 100% improvement with the constant occurring BSODs

So I reached out to on the Gigabyte Discord and got help from a user with the same issue

The following settings solved his issue:
- Enable XMP
- Set DRAM voltage manually to 1.35V
- Set RAM multiplier to 32x
- Set the first five subtimings manually to 16-18-18-18-36 (the same as XMP would) important!
- Set the sixth timing (tRC) to 56 instead of 54 as XMP would important!

Memory slots used: A2/B2

And it also worked for me!
System runs stable on 3200 without any BSOD.
Did a overnight MemTest86 and zero errors!


I believe it has something to do that the CMW32GX4M2C3200C16 is optimized for Intel and that maybe there is an issue with the XMP, that the values don't work with an AMD system.


Would like to hear if anyone using CMW32GX4M2C3200C16 on an AMD Ryzen build has similar issues and if the above fix solved any potential BSOD issues.


Update:
Latest BIOS Update from GB 10c did not resolve the issue with the XMP profile and BSOD if the timings are not entered manually.

Running stable on 10c with Win 10 v1909, overnight MemTest86 showed zero errors.

Last edited by RBurgundy; 11-13-2019 at 08:37 AM. Reason: Update with latest BIOS 10c
Reply With Quote