The Corsair User Forums  

Go Back   The Corsair User Forums > Search Forums

Showing results 1 to 4 of 4
Search took 0 seconds.
Search: Posts Made By: michicago44
Forum: System Builds, Modding, Custom Components, and Picture Gallery 02-12-2019, 07:37 PM
Replies: 0
Views: 447
Posted By michicago44
RM650x - Some Cables Missing Pins. Normal?

Hi all,

First time builder here. I set up my build yesterday and plugged everything to the PSU and was able to use my PC fine for a few hours. However, I noticed on a couple cables that pins were...
Forum: System Builds, Modding, Custom Components, and Picture Gallery 02-12-2019, 10:45 AM
Replies: 4
Views: 1,607
Posted By michicago44
Ah, you're right. But yeah, reading around,...

Ah, you're right.

But yeah, reading around, it sounds like the tach cable is purely to prevent some sort of freakout in some mobos. I've started up my computer multiple times since my build was...
Forum: System Builds, Modding, Custom Components, and Picture Gallery 02-12-2019, 02:52 AM
Replies: 4
Views: 1,607
Posted By michicago44
There's honestly nothing else coming out of the...

There's honestly nothing else coming out of the block - I can't even see it in images on the internet/installation vids. The cooler seems to be working fine without it though (lights up, radiator is...
Forum: System Builds, Modding, Custom Components, and Picture Gallery 02-11-2019, 08:38 PM
Replies: 4
Views: 1,607
Posted By michicago44
Corsair H100i RGB Platinum Installation Help H

Hey all,

First time builder here. I'm currently trying to wire the H100i RGB Platinum.

I've connected the power cable to a SATA plug and the other two wires coming from the block to the two...
Showing results 1 to 4 of 4

 
Forum Jump

All times are GMT -4. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.