The Corsair User Forums  

Go Back   The Corsair User Forums > Search Forums

Showing results 1 to 6 of 6
Search took 0 seconds.
Search: Posts Made By: naviathan
Forum: Keyboards and Mice 03-03-2014, 11:10 AM
Replies: 2
Views: 2,397
Posted By naviathan
You need to let it dry for longer than a day. ...

You need to let it dry for longer than a day. I'd give it a week and see what happens. The circuitry is pretty basic in these keyboards so water shouldn't really do a whole lot of damage if any.
Forum: Keyboards and Mice 03-03-2014, 11:05 AM
Replies: 144
Views: 307,834
Posted By naviathan
Is it possible to keep the reactive typing...

Is it possible to keep the reactive typing activated through system restarts? As it stands with my K70 after the computer restarts (presumably USB power drops and comes back up) the keyboard goes...
Forum: Keyboards and Mice 03-03-2014, 09:36 AM
Replies: 39
Views: 103,391
Posted By naviathan
If you still have issues with this and you have...

If you still have issues with this and you have your keyboard plugged in through a USB hub or a docking station, try connecting it to USB ports directly attached to the computer.
Forum: Keyboards and Mice 03-03-2014, 09:32 AM
Replies: 4
Views: 3,781
Posted By naviathan
Solution found. Apparently it's the docking...

Solution found.
Apparently it's the docking station for my HP laptop. We have several laptops in the office that use docking stations and the docking stations have USB hubs built into them....
Forum: Keyboards and Mice 03-03-2014, 09:27 AM
Replies: 4
Views: 3,781
Posted By naviathan
That's a negative GhostRider. The service restart...

That's a negative GhostRider. The service restart did nothing. Plugging it into another windows box did nothing (Both BTW are Windows 7 64bit machines). The keyboard registers two HID Keyboard...
Forum: Keyboards and Mice 02-28-2014, 09:22 AM
Replies: 4
Views: 3,781
Posted By naviathan
Volume Roller not working on K70 ***SOLVED***

This isn't working with the K70 in windows. Volume roller does nothing but the HID service is running and autostarts. Why is it the K70 is the only keyboard in the K series that doesn't have any...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -4. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.