The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Legacy Corsair Software (https://forum.corsair.com/forums/forumdisplay.php?f=267)
-   -   Launch Application - Focus Bug (https://forum.corsair.com/forums/showthread.php?t=169463)

Willis 07-26-2017 11:21 AM

Launch Application - Focus Bug
 
This has been happening and driving me crazy since I first started using the CUE software last December.

OS: Windows 10 x64 (but on multiple machines, edit: including clean installs with only CUE software installed)
CUE Version: All up to and including 2.15.83

Problem description: When the CUE software is not recently activated but running, if you press a key that triggers a "Launch Application" action (any of the pre-populated list or custom executable paths), the application will open, but it will not be focused. To further the problem, simply selecting the newly launched application from the taskbar or clicking on it's title bar does *NOT* grant keyboard focus to the application. You must mouse click within the application window in order to get keyboard focus.

Reproduction: This is where it gets difficult, as it does not happen all of the time, but for me, it does seem to happen more than 90% of the time. There is no guaranteed reproduction method, but the following seems to trigger it.

1) Open the CUE window
2) Open any other application not using CUE software (I typically launch a web browser). Mouse-click in this application to ensure it has focus.
3) Press a key that CUE is set to launch an application (I typically use calculator built-in)

Step 3 launches an application that is out of focus and requires unusual extra steps (clicking within the application even after clicking it to focus on the tasktbar) to gain full keyboard focus.

If the CUE software is in focus, the newly launched application always launches with correct focus. If the desktop is focused, it is hit or miss which will get focus. If another application has focus, I'd say about 75-90% of the time the newly launched application does not gain proper focus.

Additional information: Any time I get this issue, if I simply open the CUE software and close it, my chances of getting correct focus increase, but are still not consistent.

Any help would be appreciated, but I'm assuming this will need a CUE patch in some regard.

Corsair James 07-27-2017 09:36 PM

I'll see if we can reproduce this. Thanks for reporting it.

MQs 09-23-2017 03:45 PM

EDIT: I thought I've solved it, but bug returned after ~24 hours. It might be a clue though, because it worked for unusually long time.

Quote:

This random focus losing behavior happend to me when I was trying to run Windows Calculator, and the problem appeared to be linking the wrong version.

In x64 Win systems there are two calc.exe apps - 32bit version in c:/windows/system32 and x64 in c:/windows/sysWOW64. Linking to 64bit version for key assigned action (and profile switch in my case) solved the issue.

Willis 09-27-2017 08:57 AM

It's not a 32bit vs 64bit issue, it happens on applications that only have a single executable, and it doesn't matter which. It's an issue of how the launch function is executed.

The bug is still present in 2.18.81

stokboy 10-05-2017 12:43 PM

I can confirm that I'm also experiencing this bug on Windows 7 Enterprise 64 bit. Just picked up a K70 Lux, downloaded the latest CUE, mapped this to calculator, and it generally opens up behind other windows, not in focus.

Thanks

Willis 11-29-2017 11:59 AM

This still has not been properly addressed through Cue 2.20.72, the issue remains open.

Willis 01-03-2018 10:20 AM

Bump - bug is still present in 2.21.67

Willis 03-18-2018 12:43 PM

Bump - Still an issue in 2.24.35. Corsairs ignoring of bugs is really starting to become a problem to me.

Corsair CJ 03-18-2018 02:10 PM

Quote:

Originally Posted by Corsair James (Post 913628)
I'll see if we can reproduce this. Thanks for reporting it.

Quote:

Originally Posted by Willis (Post 945324)
Bump - Still an issue in 2.24.35. Corsairs ignoring of bugs is really starting to become a problem to me.

I've tried this on a number of versions of CUE and it's worked fine with multiple applications. I'll ask James if it was addressed in a specific version and/or if he was able to reproduce it on his end when he first responded.

Edit:
Managed to reproduce it with notepad, but only if I execute the launch app macro with desktop in focus and no other windows onscreen. I'll reach out to James as mentioned before.

stealthycow 06-09-2018 06:07 PM

I have the same issue as OP on 2.24.50, macro button launching calculator. usually it doesn't work same as OP (application is not focused, after clicked in the taskbar to focus it requires clicking on application window to get full keyboard focus). sometimes it'll work properly, and like OP it seems like if I open up CUE and then close it, it'll work more reliably for a while but then go back to not working.

Rashiro 08-14-2018 03:44 AM

This error is still present in iCUE 3.6.109. Sometimes it fixes itself randomly, I haven't found any logic in it yet.

Willis 08-14-2018 09:26 AM

Yeah, it's been present in CUE 3.5 and 3.6

We're past the one year report of this bug, I've lost all faith it will ever get addressed by Corsair.

Rashiro 08-15-2018 08:44 AM

I found a fairly simple workaround. Just remap the G keys to the function keys F13, F14 and so on. Then get a third party macro editor (e.g. AHK) and map the function keys to run the applications you want.

DJF 10-27-2018 12:31 PM

Hi all,

I had the same problem. To resolve I changed the Windows registry value of:
FOREGROUNDLOCKTIMEOUT
located at
HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP
from
30D40 (Hexadecimal) or 200000 (Decimal)
to
0
Rebooted my machine and the macro buttons now open applications in focus in the foreground.

Further details of this problem at the below thread:
https://windowsforum.com/threads/new...windows.91026/

Thank you and I hope this helps someone.

Willis 11-08-2018 10:50 AM

Thank you for that, it does appear to work fairly well, though the point still stands that users shouldn't have to modify their registry to fix software bugs.

Also, the invisible Powershell/Command prompt bug still exists just the same.


All times are GMT -4. The time now is 09:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.