The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Commander Pro is DEAD (https://forum.corsair.com/forums/showthread.php?t=171804)

xldeane 10-16-2017 11:10 PM

Commander Pro is DEAD
 
Hi Gents a little help here please.. Im just finishing off my new build. Im using a 570X case and I have fitted 6 HD120 RGB fans. All the cables and wires going to all the right places.. I started her up about an hour ago, everything started fine,all the fans were spining, some faster than others I might add but the LEDs on the fans were dead..

I opened Corsair Link I could see the fans but they were spinning at different RPMs and very erratic. I thought it may have been the Lighting Node/Hub so I swopped it out with a spare that I bought with the fans, I then noticed that the Commander Pro has a LED by the temp connectors it wasnt alight.. I checked all the connectors. There is definatly power getting to the CP because it coming from the same power cable that goes to the HHD.

I read on this forum something about a firmware roll back is that what I have to do to get this bloody thing working ?? Its 4.00 in the morning I have been putting this machine together all night and the CP lets me down.. Any help appreciated.

Thanks

xldeane

Zotty 10-17-2017 03:30 AM

Hi Buddy

1.the led on the commander pro only lights up when it is communicating with other devices (psu if an 'i' series and plugged in etc)

2. fan led's.. did you add them in Link Led configure drop down menu?

3. as for rolling back commander pro or node pro... here you go buddy

http://forum.corsair.com/v3/showthread.php?t=171536

xldeane 10-17-2017 03:52 AM

The LED hasnt lit up all night, thats how long of been working on the bloody thing.

OK Zotty.. this is your fav topic.

Corsair 570 X, HX750W Platinium PSU, Asus Stix Z270E Gaming motherboard, 500g M.2, 4TB HHD, i7-7700K, Fractal design S36

Im am using 6 HD 120 RGB fans, All 2 a pair of 4 core ribbon cable, 1 Cable has a Lockable SL Connector terminal. All 6 of those cables I have fed down to Corsair LED Light Hub. The other 4 core ribbon cable from 6 fans got to Commander Pro into Fan Headers No 1-6, which is in the same sequence as the cables going to Led Light Hub. All items in this build are brand new. One cable form the Light Hub has its own designated Sata power lead straight from PSU, the other cable goes to Com pro Led channel 1.
2 cables coming from top of Com Pro, 1 goes to Sata power, (I know this is live because its same cable that powers my HHD.
The other cable goes to USB 3.0 on header at bottom of motherboard. 4 Temp senses on headers going to various points in case.

Corsair Link is running and it picks up all 6 fans and according to Link they are flashing away like mad...only there not there dead.. The fan front bottom (No 1) is the only fan working.. I take it in turns to run all my fans through channel 1 just tpo ensure they are all working, which they are. I have 2 spare Lighting Hubs so I wire each one in a test. Still only fan No 1 working on all 3 light hub tests ?? Com Pro has a LED thats not made a flash for the past 8 hours. The New build starts ok runs like a dream Fans are running well although some are running faster than others (even next to each other.

Any Ideas mate ???

xldeane 10-17-2017 03:57 AM

As for Downgrading the CL4 I have I took it back to a time before it had HD120 RGB on the list and had to bring it forward so it picked up the HD 120 RGBs...
That didnt do the trick either....

Zotty 10-17-2017 05:30 AM

Dont suppose you also have the Node pro to try to confirm Commander issues?

xldeane 10-17-2017 10:22 AM

No sorry mate I don’t, but I uninstalled Corsair Link with a 3rd party uninstaller and managed to get 5 of my 6 fans running with RGB flowing out everywhere. I reinstalled Link and guess what ?.. They have all disappeared again. No sleep last night..I’m getting bloody annoyed with these goods. I have a good mind to RMA the bloody lot. Commander Pro, 7 HD120RGB fans, the PSU even the Case can go back !!!

Zotty 10-17-2017 10:54 AM

have you tried rolling back the commander driver to the one in the link i sent you?... no t Link its self?

Corsair Dustin 10-17-2017 12:28 PM

It honestly just sounds like you had bad luck and got a bad Commander Pro. Not a common problem by any stretch of the imagination, but even if one out of every 500 fails...well, someone always gets that one.

I'd recommend contacting customer service and letting us take care of this for you.

xldeane 10-17-2017 04:03 PM

LED's
 
Hi Justin,

Thanks for getting back to me, I was under the impression that the Com Pro took charge of fan speed and Light node/hub looked after the LED's ?? My fan spin OK power up they go faster power down they slow. Its the LED's that Im having problems with ?? And Im 90% sure its Link software that's buggy....

Thanks
xl

xldeane 10-17-2017 09:27 PM

Nooooo
 
I don't get this, I have stripped out the Com Pro & Lighting Hub. I have rechecked all of my fan and LED cables and connection terminals they are all A1. Then I went to a mates house and borrowed his Com Pro. Fitted it into my machine and exactly the same thing happened, the fans spin fine no problem, you can even adjust them using BIOS. The only fan to show any LED's is bottom front (No 1). Already tried 3 LED hubs today and problem persists so its not the hub.

I have disconnected Com Pro from power and reset it, I have rolled back the Firmware, updated all my drivers, made sure there isn't anything running that may be in conflict. and It still doesn't light up the other 5 fans.. Tomorrow I am going out to get a Light Node and set it up and run fans back to Com Pro using that. If that doesn't work its all going to be RMA'd. Getting a bit fed up now ...I never have this problem with Logitech stuff !!!


xl...out

Corsair Dustin 10-18-2017 12:14 PM

The diagnostic work you did with your friend is actually really helpful in diagnosing the issue.

It sounds like there's a bad LED in one of the fans.

Basically the way the LEDs in these work is like a strand of Christmas lights. If you have a bad LED, then the signal stops at that LED, and the rest of the LEDs on the chain don't get their instructions and don't light up.

SpeedyV 10-18-2017 01:13 PM

You know, looking back through all the various posts about Commander Pro woes, LEDs not lighting, driver signing issues, firmware upgrades & down grades, Link upgrades & downgrades, I cannot remember a single case wherein the customer RMA'd his/her Commander Pro, got a new one, and reported that this solved the problem. In every case, it has ended up being software / firmware related.

I think the Commander Pro itself, from a hardware standpoint, is actually rock solid. I have managed to lock mine up a few times when sending instructions from SIV that are outside of the normal Corsair range, but it has always come right back up after a firmware re-blow. I also would not expect Corsair to worry about issues that only occur when commands are sent outside of what is possible with Link.

The only negatives I can think of that are Commander Pro Hardware related are:

1 - It seems to be fundamentally limited on how complex the LED lighting patterns can be. Hence the migration to a software based control system.

2 - The firmware has an arbitrarily low limit of how many LEDs can be addressed.

3 - The PWM driver seems to have problems with some non-corsair brand PWM fans (though this has been rectified for at least some fans like Noctua).

I still cannot find an example of the problem being a bad Commander Pro. Am I wrong on this?

xldeane 10-18-2017 07:47 PM

Dont think so...
 
Quote:

Originally Posted by Corsair Dustin (Post 923708)
The diagnostic work you did with your friend is actually really helpful in diagnosing the issue.

It sounds like there's a bad LED in one of the fans.

Basically the way the LEDs in these work is like a strand of Christmas lights. If you have a bad LED, then the signal stops at that LED, and the rest of the LEDs on the chain don't get their instructions and don't light up.

I hear what your saying Justin I really do, but yesterday morning I only had 1 fan working (Spinning+LED) that was on channel 1. So I de-rigged all the fans and tried the other 5 fans through the Commander Pro and Light hub all on channel 1 and every single one of them worked fine, I am very thorough to the point of OCD... I personalty do not think its the fans. The only common denominator is the software. I have used every single piece of Corsair Link software you have all the way from 4.0.077 to 49057. I have used a very good 3rd party uninstaller to completely clean the previous Corsair Link from my machine then I have rebooted, re-scanned and then installed the next version. I still have exactly the same problem that I started with. I have used 3 light hubs, 2 Commander Pro. I have in total 15 fans (only 6 in machine) I have ordered from Scan a brand new Commander Pro and I have also ordered a Light Node Pro to see if I can cure this problem another way...

Any advice from the people who designed and made these items very much appreciated.. Im just one of the mugs that buys and installs them.

BTW. I have a top spec 3400 machine sitting there that I cant use because of some dodgy 50 piece of.......bought from Corsair. I asked for an RMA number yesterday morning and I'm still waiting for a reply from Customer support...

Thanks

Deane

xldeane 10-18-2017 07:53 PM

Justin ? Is your title correct ? Your the Product Manager for Corsair Link software ? Were you in charge of overseeing how this software was written and you obviously had to sign it off to say its all good ? Do you oversee the updates and the Firmware as well ??

xldeane 10-18-2017 07:57 PM

My fans now show up in CL as lighting strips.. this is getting worse !!


All times are GMT -4. The time now is 12:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.