The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   K70 LED Light issue (https://forum.corsair.com/forums/showthread.php?t=119701)

cellwood 12-13-2013 03:42 AM

Quote:

Originally Posted by Oddwunn (Post 667976)
I have K70 that is about a month old or older (bought it the first day it was released on Newegg). I leave my computer on 24/7 and all was well UNTIL I went on vacation. I shut down for vacation, and when I powered back up, I have found 5 keys that are no longer backlit - both "shift" keys, "M", "O", and "1". In the programmable mode, the left "shift", the "1" and "M" will light VERY dimly, while the "O" and right "shift" are completely dead. In the "full keyboard lit" mode all 5 keys look to be completely off, though I can't be sure, as the light spills over from other lit keys.

Ram guy, you want mine back?

Almost the same situation for me. I leave the PC on 24/7 but turned it off and unpluged from the wall for 7 days while on vacation and came back to 2 dead LEDs. Esc and numpad 7. Good times...

http://s28.postimg.org/96wmn1uzh/IMG...213_022135.jpg

shadowlawz 12-13-2013 05:03 PM

My K70 has just started losing LED's 1 by 1. It started with the left Windows key, then the letter M and now Tab. I have opened an RMA request Ticket#6313350 however they are asking me to provide a receipt when I bought this KB in September. Ramguy can you help me with this please? Thanks in advance!

Hexogen 12-13-2013 06:28 PM

I bought K70 2 weeks ago, and now i end up with 18 dead LED's, its a Silver edition with blue backlight(blue switch), is this really isolated problem?

gdg 12-14-2013 12:01 PM

Known issue with LED both Blue and White
 
I spoke with two different Corsair tech support personal yesterday 12/13/2013 regarding this issue with the LED lights burning out after a short period on both the K-70 (Blue Lights) and The K-95 (White Lights).

I was told that they knew about the issue, have identified the lot of bad LEDs (first time I heard them even admit there was an issue) and have currently “fixed” the issue with the supplier.

I was told that if I ordered directly from Corsair and the unit was shipped directly from their warehouse they could pretty much guarantee me I would not have the same LED issue that others were having.

They also said currently, they could not guarantee what lot I may get if I ordered the product from Newegg, Amazon or one of their other vendors.

A few days ago Newegg was “Out of stock“ of the K-70 (Gunmetal Browns blue leds)

Called and spoke with Newegg, told them what Corsair had said, agent looked up current inventory, and found they had just received 192(Gunmetal Browns blue leds) this Tuesday the 10th.
I can only assume these 192 are from the current fixed lot.

Bottom line: Corsair has identified the problem, taken action to fix the problem, but there may be a few of the old bad lot floating around in some vendors inventory.

Roll the dice….or order directly from Corsair for the next couple of months. :D:

wytnyt 12-14-2013 12:08 PM

yup ordering from a vendor other than the Corsair store can result in getting older stock,i just received a Air 540 and am hoping i dont have its cable issue.

Angrychair 12-14-2013 05:07 PM

so does this problem not affect red led boards?

MihaiEU 12-14-2013 09:12 PM

Quote:

Originally Posted by gdg (Post 687467)
I spoke with two different Corsair tech support personal yesterday 12/13/2013 regarding this issue with the LED lights burning out after a short period on both the K-70 (Blue Lights) and The K-95 (White Lights).

I was told that they knew about the issue, have identified the lot of bad LEDs (first time I heard them even admit there was an issue) and have currently “fixed” the issue with the supplier.

I was told that if I ordered directly from Corsair and the unit was shipped directly from their warehouse they could pretty much guarantee me I would not have the same LED issue that others were having.

They also said currently, they could not guarantee what lot I may get if I ordered the product from Newegg, Amazon or one of their other vendors.

A few days ago Newegg was “Out of stock“ of the K-70 (Gunmetal Browns blue leds)

Called and spoke with Newegg, told them what Corsair had said, agent looked up current inventory, and found they had just received 192(Gunmetal Browns blue leds) this Tuesday the 10th.
I can only assume these 192 are from the current fixed lot.

Bottom line: Corsair has identified the problem, taken action to fix the problem, but there may be a few of the old bad lot floating around in some vendors inventory.

Roll the dice….or order directly from Corsair for the next couple of months. :D:

They are lying. I got mine last week and already have a dead LED. On the other hand, they explained long RMA with huge demand (so mine should be a new batch since old ones are gone due to demand). I wouldnt trust them, rather exchange for a black one.

gdg 12-15-2013 01:01 PM

You bought yours from Amazon, not directly from Corsair as I was told to do by their tech support staff. Anyway, I am holding off on the K-70 until after the first of next year hoping that all the "bad lot" will be gone.

:mad: Unfortunately, gone means, have been purchased by other customers like yourself which now have to deal with Corsairs quality control issues.

Also, I am going to wait and see what happens with the new Cherry MX RGB switch and the exclusive deal they have with Corsair. Updated LEDs with 16.7 millions colors.
http://www.cherry-professional-gaming.com/EN/index.html

Regarding the current K-70, they should have just pulled the bad lot as soon as they identified the problem.

As I see it, I think they believed this to be just a small percentage of their overall K-70 K-95 sales so why bother, just have those with issues RMA the bad units.

Personally, I think Corsair would have gotten more respect if they had just pulled the units, which I would have interpreted as a company looking out for their customers.

One last thing: I mentioned to the tech support guys that someone from Corsair should release a statement on this forum confirming this issue had been "fixed" but it has been tough, if not impossible, just getting them to admit there was an issue in the first place. I have never seen them do so publicly in their own forum.

eternitykh 12-17-2013 08:13 PM

As a loyal corsair customer and fan (i literally own products in every single category corsair offers, and solely build with corsair PSUs for all my personal, client's, and friend's builds), I have been recommending the k70 to all my friends and gamers I know that are looking for a new keyboard, especially after they released them with browns and blues. I have also been aware of the LED issues that have been arising on boards with blue LEDs (and some k95 whites).

I myself had a k90 and that never had any LED issues. I now own a black/red k70, also never had issues.

I hope the issue is truly resolve as I don't want to regret recommending to so many people a faulty product with corsair's reputation on the line, as this is the first corsair accessories to most of them.

cellwood 12-24-2013 07:22 PM

So corsair decided to delete my post asking for a CSR to at very least comment on some of this. A CSR hasn't been on this forum for over 30 days. They have time to censor the forums but not respond to customers. gg. This keyboard is the last time I buy anything from this company. Should have gone with a quality product/company....

Im still waiting for my prepaid mail slip to send this keyboard back...

Technobeard 12-25-2013 02:29 AM

Quote:

Originally Posted by cellwood (Post 689190)
So corsair decided to delete my post asking for a CSR to at very least comment on some of this. A CSR hasn't been on this forum for over 30 days. They have time to censor the forums but not respond to customers. gg. This keyboard is the last time I buy anything from this company. Should have gone with a quality product/company....

Im still waiting for my prepaid mail slip to send this keyboard back...

It was not deleted, it was moved to its own thread: http://forum.corsair.com/forums/showthread.php?t=124899

cellwood 12-25-2013 03:51 AM

Quote:

Originally Posted by Technobeard (Post 689249)
It was not deleted, it was moved to its own thread: http://forum.corsair.com/forums/showthread.php?t=124899

How about a comment on the k70 issues we are all having?

travisamc 12-27-2013 10:05 PM

Same problem here, ordered mine from the 1st shipment of K70's (MX Blue).
I turned on the computer after a few days off and the "Delete" and Keypad "#5" LED's are both out.
I filed the RMA but after a few attempts I couldn't find the Part Number, the search Function doesn't work even for the products that I see on the page...weird.

xBladeM6x 12-29-2013 11:27 PM

I really want to get the Keyboard (Red Led / Cherry Red MX) but reading about all these LED failures has pushed me away, even though this is pretty much my dream Mechanical KB setup. If a Corsair Mod has an info / will say that this is just an issue for certain people and not almost all, then I might reconsider. I just don't want to get the thing and have stuff die in a couple months all because of a manufacturing issue.

sachielAdji 12-30-2013 01:14 PM

I've received my 2nd replacement, and the extra keys/puller are packaged differently, so I can tell it's a different batch to what I've had previously. Wish me luck!


All times are GMT -4. The time now is 09:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.