The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   K55 Not Recognized By BIOS/UEFI (https://forum.corsair.com/forums/showthread.php?t=169810)

bdove88 08-10-2017 01:42 AM

K55 Not Recognized By BIOS/UEFI
 
Hi I have an Asrock H61M/U3S3 motherboard, and I cannot get into its UEFI or even select the boot menu with my Corsair K55 keyboard. I read that the K70 and K95 models had a similar issue but that was a few years ago that those threads were written/posted into, is there anything I can do to allow the motherboard to detect it in the UEFI/BIOS? Is this still an issue? How can a keyboard not be usable for getting into the UEFI/BIOS?

I have Legacy USB enabled in the UEFI, and I know that USB keyboards can be detected because I have already tried and can successfully access the UEFI with an extra USB keyboard I have here at home.

I have already tried plugging into every single USB2.0 port.

Toasted 08-10-2017 07:46 AM

Try putting the keyboard into BIOS mode.
F1+Windows lock key. The Scroll lock indicator should start flashing. To exit, use the same key combination.

Alternatively, If you are on Windows 10, you can boot into the UEFI via Recovery > Advanced Startup in Settings.

bluucat 02-20-2018 10:31 AM

my whole pad is blinking and whenever i press win lock and F1 it opens chrome, and searches up windows help.

Toasted 02-21-2018 06:34 AM

Open the start menu and then press F1 first followed by Windows lock, Not the reverse.

SoxmisUK 02-27-2018 11:35 AM

Hi I just bought a K95 and have been struggling to get into my BIOS with it too, several times I had to plug in my old knackered Steelseries to access the BIOS and it's a USB device too, but, came across this thread and Bingo! Got right in first time! Thanks!

Is there any other fix available that will permanently cure/fix this? - Is it a windows problem or a bug with the K95 KB?


All times are GMT -4. The time now is 09:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.