The Corsair User Forums

The Corsair User Forums (
-   Corsair Link (
-   -   Discuss Link v4.9.9.3 here (

Technobeard 01-28-2019 05:48 PM

Discuss Link v4.9.9.3 here
This will be the official discussion thread for Link v4.9.9.3.

If you'd like to report a bug, please respond to this thread in this format:
  1. Version of your Link software. NOTE: If you're not using v4.9.9.3, please install it and see if the bug has been fixed.
  2. What version of Windows you're using.
  3. Summary - One line / sentence explaining the issue
  4. Detailed description of the issue - This part can be as long as you want. It should be detailed enough so that we can clearly identify the issue and attempt to replicate it.
  5. Attach photos of the issue to the post that help #4.


Release note:
  • Maintenance release to fix security bug.

kylsifer 01-29-2019 09:06 AM

Discuss Link v4.9.9.3 here
My corsair Link wont allow me to update to v4.9.9.3, It keeps saying "Cant download updates now. Please Try again Later."
I'm on link v4.9.7.35 and I'm using Windows 7, so is it something on your end? or is there a file I can download somewhere.

William1 01-29-2019 11:55 AM

When will this be on the site for D/L? Can you provide a link to it? I prefer to retain a copy of all installed SW in case I want to reinstall.

jaf 01-29-2019 12:19 PM

Same problem -- always "Cant download updates now. Please Try again Later."

byozz 01-29-2019 12:55 PM

new version does not see ; h100i

jaf 01-29-2019 01:16 PM

Thanks for the info. I have a H100i v2, so I suspect it falls in that category.

I won't update then until there's a fix, if ever.

ensign.fodder 01-30-2019 12:37 AM

I have a H100i Extreme Performance (CW-9060009-WW) and did install over existing v4.9.7.35 and it was seen right away and kept all my settings.

Win Server 2016 OS.

The v4.9.7.35 would not see the update since it was unable to communicate but v4.9.9.3 says I am running most current version.

Hope this helps.

kazavasoy 01-30-2019 03:43 PM

You can download it directly from Corsair site:

Press "load more" and you'll see it as the second download option of Corsair Link.

jaf 01-30-2019 03:50 PM

The problem was check for updates and a constant "can't download now ...."
I download it from Techspot (thanks dc8flyer) and it installed and is working fine.

Pondering 01-30-2019 04:13 PM

1) Link v4.9.9.3
2) Windows 10 Pro, Version 10.0.17763 Build 17763
3) Corsair Link is not detecting GTX H100i and reading AMD Ryzen 5 2600 package temperature ~+60C above other applications. Fan header set to 100% and USB plugged into only USB2.0 header on motherboard.

Edit: This is a new PC build, none of the versions of Link detect the GTX H100i.

William1 01-30-2019 05:44 PM


Originally Posted by kazavasoy (Post 991959)
You can download it directly from Corsair site:

Press "load more" and you'll see it as the second download option of Corsair Link.

Thanks. I did not see the 'load more' You'd think the most recent would be the top of the list, right?
I appreciate dc8flyer providing another source but I am more comfortable getting it from the source rather a third party.

Templ4r 01-30-2019 06:17 PM

so this new version will not be recognizing the below?

Corsair Hydro H110i 280mm Extreme Performance

Haven't tried yet but i see that H100 will not be according to some comments.

optodata 01-30-2019 07:30 PM


Originally Posted by kazavasoy (Post 991959)

Press "load more" and you'll see it as the second download option of Corsair Link.

Thanks for pointing this out! I missed it the first time I checked, too. :sigh!:

Templ4r 02-02-2019 02:49 AM

will trying to install the latest version update the current one? since the auto update doesn't work..


just tried to upgrade and it did, also saved all my settings.
thanks for making a software upgrade a breeze..

my Corsair Hydro H110i 280mm Extreme Performance is visible.

is there any plan to make the SSD/HDD temperature visible again since it was removed 2 version ago due to sleep prevention? perhaps iCUE has this feature instead?
was also surprised LINK got an update since i thought its discontinued, being replaced by iCUE (although from the change-log there is no new feature so it might be correct).

GuruSR 02-03-2019 01:13 AM

Not entirely sure how this is getting that result.
1 Attachment(s)
But do the authors of Link see what is wrong in this picture? Now I've written code to get the right answer and this machine always gives me the right answer when it's done according to the proper methods outlined by Microsoft. Looks like Link thinks I never upgraded...


All times are GMT -4. The time now is 07:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.