The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   iCUE Software (https://forum.corsair.com/forums/forumdisplay.php?f=280)
-   -   Problem with iCue Display (https://forum.corsair.com/forums/showthread.php?t=191010)

Amiejay 10-17-2019 02:56 AM

Problem with iCue Display
 
Hello...

I apologize in advance if this is a FAQ - I searched, and I didn't find anything relevant.

When I run iCue (3.2.80), I get a Window without the standard Windows title bar (application name, minimize, maximize, close) sitting somewhere on my center monitor - this window cannot be moved. The application appears to be functioning, but the window that is supposed to show the devices (when you click on them) appears to be zoomed in to the point that only the extreme upper left corner of the device is visible. None of the controls that should be shown for each device are visible.

I have lots of Corsair RAM (64GB), a Commander Pro and an H115i RGB Platinum. I've also got 2 Nvidia GeForce RTX 2080ti cards, a 40TB drive array, a 1TB nvme boot drive, and some other storage devices. CPU is a Core i9 9900X. Only the Commander Pro and the H115i RGB Platinum show up as configurable devices.

Also, the only way I can close iCue is by killing it in the task manager. This doesn't seem right.

Has anyone seen this problem before? Is there any way to fix it?

Thanks!

Amiejay

c-attack 10-17-2019 06:22 AM

Occasionally if the program crashes or freezes, but it could also be a corrupted install. Since there is a new version out (3.21.88), now would be a good time to upgrade and see if the behavior changes.

Amiejay 10-17-2019 05:07 PM

Thanks - I saw other people talking about the new version, but the download link from the Corsair site still has the older version.

Is there a link to get the newest version?

-A

c-attack 10-17-2019 05:30 PM

It looks like it is up now. The website direct version usually comes within 24 hours of the in-app update version. I prefer to keep the download installer in case there are issues now or in the future necessitating a roll back.

https://www.corsair.com/us/en/downloads

Pharalex 11-16-2019 07:37 AM

I have the exact same problem as the OP aside from that I am running the latest version, I have tried reinstalling as well as running the program from program files and program files (x86) folder (as I saw that fixed some users’ issues of not being able to open ICUE in the first place)

Is there anyone who knows of any known causes and preferably a fix for this issue?

Greatly appreciated

c-attack 11-16-2019 09:34 AM

Open the task manager and quit iCUE and the Corsair services.

Go to C:Users/(name)/App Data (hidden folder)/Roaming./Corsair and cut and paste that folder to the desktop. Those are all your profiles and settings.

Relaunch iCUE normally. It should open with a blank slate and 1 default profile. If it does not, you may now need to do the repair install with the profiles removed.

If this does work, it likely means some element of your settings became corrupted. This seems to happen most often when people are trying to roll back to old versions after loading a newer one. When you install a new version, it effectively stamps the current profiles with the newest tag. Going backward is a big problem. Of course, if this does work, it means you have effectively lost your profiles and settings unless you have them backed up.

Pharalex 11-17-2019 05:28 AM

Hi,

Thank you for the swift response, really appreciate it. Unfortunately that didn't work.

I looked around on the forum and old posts and found a solution that fixed the issue;

On the program go to properties, compatibility, change high DPI settings, override high DPI scaling behavior, scaling performed by system.

I guess this issue is due to a minimum window size of 720p and I am using the program on my laptop with a 13.3 inc display currently.

Hope this information can be helpful for anyone who experiences similar issues as the OP and myself


All times are GMT -4. The time now is 10:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.