The Corsair User Forums

The Corsair User Forums (
-   Gaming Chairs (
-   -   Brand new T1 won't raise/lower (

Despite 08-02-2017 01:53 AM

Brand new T1 won't raise/lower

Just got my chair today. Put it together and it doesn't raise/lower when using the lever on the right side.

It seems I didn't remove the red cap from the gas lift. How can I get to it now that the chair is put together?


kiddsupreme 08-16-2017 12:12 AM

I also too have this problem. Got it about a week ago, and put it together. Doesn't raise or lower. Any help would be appreciated.

itsallpoo 09-05-2017 04:46 PM

You should be able to make the gas cartridge come off the bottom of the chair but it may be a little bit of a job. Most likely you will have to unscrew the bracket from the bottom of the chair and from there you should have access to the top of the gas cartridge, from here it could be easy or difficult, you will probably need a hammer and a punch sort of long metal thing that you can strike with the hammer on the top of the cartridge to push it out. You'll need two people or a bench with c clamps that can hold the chair while you insert the punch in the hole and hit it with a hammer. Obviously don't go hulk on it but you should be able to just pull upwards and the wheeled base will come off but getting it out of the chair bottom is the tough part. All office chairs are the same way to get the gas cartridge out. If it turns out to be a bad cartridge you can order replacements on ebay not too expensive unless you need one of the heavy duty ones for big folks and it doesn't hurt to order the ones for the big folks if you don't need it because they should last longer because they are made for more weight. I think I paid 40.00 for my last gas cartridge for 300 lb capacity. You will need a couple of measurements to get the right cartridge if they don't have a model list a good listing will show you where to measure etc. You also need to know how long the cartridge is, doesn't hurt to get a longer one unless you're a short person, too high you can't put your feet on the floor anymore. It looks tough but it's not I've changed them on several chairs a lot cheaper than a whole new chair and cheaper than shipping it back too!!!

eddie.klo 10-11-2017 07:01 AM

The problem seems to be quite easy to solve. The problem is the red cap that remained on the top of the gas lift. You have to remove the gas lift from the seat. To do it, bring the chair into the horizontal position, then remove the lift by pulling it out with the aid of occacional strikes on its base. Some people recommend using a hammer with plastic/rubber cover, but I've managed to do it with the heel of my hand. After you managed to disassemble it, just remove the cap and put the seat back. Then the lift operates properly. Hope it helps...

justavisitor 03-08-2018 12:21 AM

Hi! This just happened to me and I fixed it. I had a swivel barstool and I put it together but forgot to remove the cap. Then the cap got stuck inside the chair tube. So I unscrewed the seat from the pole, and then I could see the top of the cap. I took a pair of Pliers and then hammered the closed pliers into the top of the cap, and it popped out. Just make sure whatever you use isn't too sharp so that it pushes the cap rather than puncturing it. I hope that all makes sense!

Hundtärning 02-03-2019 11:10 AM

I mounted the gas lift with the red cap on as well...

It's really easy to remove the cap, and you don't have to use a hammer.

1. Un-screw the "mechanism" from the chair, with the wheel and everything on.
2. Remove the cap with the "don't touch" on it.
3. Remove the red cap from the gas lift (seen in the attached picture).
4. Then put everything back together.

Corsair Mint 02-04-2019 07:26 PM

Unfortunately, on the T1 models, you would have to pull the seat mechanism away from the top of the gas cylinder to get at the Red cap, the photo from Hundtärning is the T2 model with uses a slightly different design for where the top of the gas cylinder is located.

Taro 02-06-2019 11:04 AM

Just happened to me as well with a T1. I'm now probably going to break it trying to remove the red cap.
Not being able to disassemble it later on when requiring to remove this cap seems like an incredibly stupid design choice. Really disappointed.

monler 05-02-2019 02:32 PM

Corsair t1 fixed the issue
I've tried multiple times to pull the gascylinder from the top, bu you can't. Simply hit the metal that connects with the top of the gascylinder 3 times semi hard with a hammer (nylon hammer recommended), and the gascylinder should release from the other part, and you can pull the red cap off and reassemble.


monler 05-02-2019 02:33 PM

See my guide in comments, it's really easy, and I did you after a year without being able to lower and rise the chair.

All times are GMT -4. The time now is 07:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.