The Corsair User Forums

The Corsair User Forums (
-   SSD Firmware Update (
-   -   Firmware upgrade with Linux -- It works! (

mactalla 10-13-2012 02:08 AM

Firmware upgrade with Linux -- It works!
Being happy with my Corsair RAM & PSU I didn't think twice about getting a Corsair SSD. Too late did I discover the .. err situation w.r.t. upgrading the firmware. Honestly I was shocked. But lemons and lemonade, etc.

Thanks to Yellowbeard for this little tidbit:

Originally Posted by Yellowbeard (Post 556587)
Our firmware packages and the update tools both come from SandForce in their complete form.

It's nice to know that the firmware is a clean drop from SandForce with nothing special done to it. I was able to confirm that only the header is different between the .vic files as delivered by Corsair and the firmware releases by other SandForce vendors.

What this all means is that the firmware updater also is nothing special (cf. again Yellowbeard's comment). I can confirm that the Linux firmware updater for SandForce SSDs is not vendor specific. I know I can't mention anyone by name, so I'll just mention that Wikipedia has a nice list of SSDs with the SF controller. A number of those do distribute the Linux updater (sadly not our Corsair...)

For reference:
I flashed a 60GB Force 3 SSD from fw ver 1.3.3 to 5.03 using Updater version under Kubuntu 12.04 64-bit and it couldn't have been easier. No mucking with boot disks, Windows, or other nuisances. I noted that more than one vendor is distributing that exact version of the Updater so really it doesn't matter where you get it from.

Hopefully Mac users can benefit from this information as well.

xdarma 10-24-2012 03:26 PM

Good to know, thank you for sharing. :sunglasse

FrankT 10-27-2012 09:24 AM

Follow up
Hey there !

@mactalla: Thanks for heads up; you saved me alot of hassles; I was hesitating between buying a Windows license or giving up a perfectly good drive.

Sorry for the post redundancy, but I was hesitating at first and figured that some people would be a tad more confident hearing it in stereo.

So :

Ubuntu 12.04 64 bit on ASUS P8Z77-V PRO. I build a few of these system but only one with a SSD (a treat to myself !) on which I had random system freezes on a daily baisis (while the others did not). Flashed my Force 3 GT from 1.3.3 to 5.03 and it never happened again (roughly two weeks now, on a busy system running 24/7).

The "LiveCD" solutions work, and then there are a few who just ship the SandForce tool to run it on your own OS... it's the same tool... I would suggest not bothering with the LiveCD.

For those who still hesitate, let me add that the tool shipped for every sandforce drive is exactly the same let it be for a bit of branding; you can follow up with Corsair's HOWTO pdf (see Yellowbeard's posts). You will, of course, need to grab the firmwares from Corsair...

have fun !

dOCZ 11-15-2012 12:49 PM

could you please tell me which tools are needed??

Im currently using a Force GT 120 + Macbook Pro.

Used to install windows via bootcamp, do all the tricks to make AHCI running then finally upgrade my firmware..

but using a live cd or even some native mac utility would help me a lot ;)

soo... where can I find this "Sandforce firmware linux updater"?? the only one I found was the OCZ version =/


mactalla 11-15-2012 03:13 PM

Around here they don't want anyone to mention a competitor by name. Please refrain from doing so in the future.

You have already found the correct tool. Sandforce creates and distributes the firmware updater to the SSD makers who uses their (Sandforce's) controllers (Corsair + others). These SSD manufacturers slap their name and sometimes their logo on this software but otherwise do not modify it. That means that the firmware updating tool is functionally identical. Just ignore the visual differences as it is irrelevant.

Now, what tools do you need? You say you have a Mac. Do any manufacturers of Sandforce Driven SSDs offer a Mac updating tool? (That's not rhetorical, I never looked into that). If someone does, then go ahead and use that.

Otherwise, you'll want a Linux updating tool. You want either the stand alone tool that you would run after booting any Linux LiveCD of your choosing, or you can get a pre-built LiveCD that contains the updating tool. I know there are at least 2 manufacturers who offer the stand alone tool. I used one of those. I also know at least one manufacturer who offers a Linux LiveCD with the updating tool built into it. I don't remember who that one was since the non-LiveCD is easier for a machine that is already running Linux.

Again to emphasize: the software to upgrade the firmware can be obtained from any manufacturer, but the firmware for your specific drive must be the exact one that Corsair tells you to use.

Hope that clarified things.

dOCZ 11-15-2012 08:15 PM

thank you, for explaining these things !

ok then !

sorry for the brand mentioning, just wanted to be specific..

guess Im going to use that tool after all haha

mactalla 11-15-2012 08:26 PM

There seem to be a number of Mac users here. I'm sure they'd all appreciate hearing your experience after you've done your update. Especially with your experience going through the Windows update previously you could provide good advice for any Mac user who still needs to do an update.

You might want to start a new thread with that info, though. Not sure how many Mac users read through a Linux thread :)

dOCZ 11-15-2012 09:05 PM


just tried the "all new mac iso"...

not sure if it's the same thing (there's a linux one, pretty identical) you had mentioned before, but well, nothing happened =[

it says my drive is not supported hehe

could you point me the updater's magical path, that you used?

mactalla 11-15-2012 09:45 PM

I don't know the policy for a link like that, so I've PM'd you the link for the one I used.

Since you're on a Mac, you'll need to run it from a Linux environment. So grab yourself a LiveCD. Something like should do the trick. Put that on a disk or flash drive and boot it.

Now you want to be able to access the firmware updater + firmware from within the LiveCD. You can download it while you're running the LiveCD, or copy it over by other means (another USB key or similar). I would guess LiveCDs should be able to read your Mac's filesystem directly, but I haven't looked into that.

Whatever way you choose, get the updater where you can access it. If you downloaded the 32bit LiveCD, then you'll want to use the 32bit updater. Similarly for 64bit if that's the one you grabbed.

Make it executable, either using the GUI (look under Properties -> Executable) or the CLI command:
chmod +x "BLEEP SSDNow SF Updater L_##Bit"
And run it.


dOCZ 11-15-2012 10:07 PM

thanks for the PM !

managed to download the zipped folder with all the goodies...

hope this ends well haha

mactalla 11-16-2012 01:17 AM

Forgot to mention that it does require root permissions in order to perform the update. If you're launching it from a shell, then prefix it with "sudo " as in:
cd where/the/updater/is
sudo "BLEEP SF Updater L_##Bit"

The LiveCD probably also has a quick access to browse the filesystem with root access that you could use to launch it graphically. But I don't know where/what name that would be. So if it's not obvious it's probably faster to open a shell.

dOCZ 11-17-2012 07:03 PM


after few tries, I will give up... for now !

I did use few distros, none of 'em listed my SSD in the updater tool =/

maybe, I need to install linux, just like the windows procedure haha

lessons learnt:

- kubuntu is fancy
- you can't run chmod commands on a FAT32 flashdrive, you must format it to a linux partition in order to change permissions/run executables
- mac really hates bootable usbs :(

mactalla 11-17-2012 10:55 PM

A shame it wasn't as easy for you. One thought is that your drive isn't in AHCI mode. Looks like (some?) Macs put the drive in IDE (legacy) mode when booting something other than OSX. If this is the case on your MBP it would explain why the updating tool fails to detect the drive. Detection only works if it can talk AHCI to the drive, otherwise it just sees a 'dumb' hdd and can't get firmware info from it. This is also why you cannot update the firmware if the drive is connected with USB.

If/when you want to pursue this, here's how to tell if you've run into this problem:
Boot into a LiveCD (any distro will do).

lspci -vnn | grep SATA
This will spit out information about your SATA controller. You will likely see "SATA IDE Controller" in which case it's running in IDE mode instead of AHCI and you can try the following steps:

From what the above command spat back at you, remember (okay, write down) the code within square brackets. eg: if you got this

00:1f.2 IDE interface [0101]: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA IDE Controller [8086:3b28] (rev 06) (prog-if 8f [Master SecP SecO PriP PriO])
then you want to remember 8086:3b28

That will let us identify the controller in computer-speak.

Now we want to have it identify itself as AHCI capable. This will vary depending on the chipset inside your MBP. If yours reports "5 series/3400 series" as in the above example, then your magic number is "90.b=60". If you have an nVidia chipset or a different series of Intel chipset then ask Google for the command for you "setpci ahci <chipset info>" would be a good search. Or post here and I'll see if I can help.

Now with those two awkward numbers we can do something useful. Run the following commands. Lines beginning with # are comments to explain what we're doing and don't actually do anything themselves. So you can skip them.


# Be root. Saves us having to write 'sudo' many times
sudo su -
# Read the current value. For debugging info.  Replace 0806:3b28 with your magic number and 90.b with the first part of your other magic number.
setpci -d 8086:3b28 90.b
# Set the value we want. Replace the magic numbers with yours.
setpci -d 8086:3b28 90.b=60
# Read it again.  It should be the new value.
setpci -d 8086:3b28 90.b
# Unload the controller
echo 1 > /sys/bus/pci/devices/0000\:00\:1f.2/remove
# Reload it.  This time it should report itself as AHCI
echo 1 > /sys/bus/pci/rescan
# Check if it worked.  This time we should see a reference to AHCI and not to IDE.
lspci -vnn | grep SATA

If that went smoothly then the update utility should now be able to probe your drive.


Originally Posted by dOCZ (Post 614117)
- you can't run chmod commands on a FAT32 flashdrive, you must format it to a linux partition in order to change permissions/run executables

The LiveCD should give you a usable filesystem that you could copy the file to, set the executable permissions, run, etc. Now since it's not backed by anything that'll survive a reboot (it's in RAM) you'd have to repeat it again the next time. It's an option if you find yourself short of thumb drives.

dOCZ 11-18-2012 12:55 PM

firmware updated sir !

too bad I didn't check your last response, I tried few distros with no success, and my first attempt was using my old Lubuntu LiveCD.

I did visit their site to check out the latest version tho... and BAAM a specific .iso for MACS !

Guess what ? I started the download, but I was so pissed off that all I had in my mind was "screw this *****, lemme try only kubuntu or ubuntu, these exotic distros will never help me".

After I posted my "giving up" reply, I went to sleep. But the SUPER SPECIAL EDITION FOR MAC ONLY that I canceled the download earlier, was whispering "come on dude, try me.. you know, I was made specially for macs, what if I got different sata drivers to detect your ssd?".

In short: I downloaded the latest mac edition of Lubuntu, booted into LiveCD mode, and I can tell you that the ending was very happy haha

So here's the deal: since you did all the brute stuff, I think it's time to create an official thread about updating our ssd using LIVE CD. I wonder how many mac users are here, and how hard is to set up a freaking bootcamp partition just to update (I know, if it's working do not update.. I know...).

obs: this reply reading must be a pain in the ***, due my awful english sorry :(

dOCZ 11-18-2012 01:07 PM

wtf mactalla, are you some sort of Linux guru? eww nice stuff there :)

I will try that with the next firmware release.

nice tip about the filesystem, I've never tried that with files from a flashdrive, even knowing that you can create stuff (like a .doc sample using the bundled office-like utilities)

All times are GMT -4. The time now is 12:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.