The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   No devices in link program (https://forum.corsair.com/forums/showthread.php?t=184253)

Helios18 01-06-2019 02:20 AM

No devices in link program
 
I just recently finished my build. My case is the Corsair Carbide Series SPEC-OMEGA RGB Mid-Tower Newegg Edition-that comes with 4 LL120 RGB 120mm fans and a Lighting Node Pro pre-installed. When I booted up the computer the 4 fans were on and functioning on the rainbow setting. As soon as I installed iCUE the fan RGB's turned off although the fans still run. I tried using the LINK software to fix the problem but LINK shows that I don't have any devices in the options dropdown menu. Also, iCUE doesn't recognize the fans/lighting node pro. Do I have a faulty Lighting Node?

DevBiker 01-06-2019 12:33 PM

Use iCUE, not Link. Uninstall Link; it won't control your devices with iCUE installed.

I suspect that you don't have the lighting channel configured. Check out the RGB FAQ in my signature.

Helios18 01-13-2019 04:29 PM

I uninstalled LINK. iCUE still doesn't show any of my fans or my case. (Only cpu cooler and peripherals). I checked all of the connections on the lighting node pro and the led fan hub and everything looks correct. 4 fans plugged into the fan hub-connected to the LNP. LNP has USB, sata power, then 2 rgb control wires-1 to the rgb fan hub and the other to the front panel case rgb. Am I missing something with the configuration?

DevBiker 01-13-2019 07:46 PM

Does the Lighting Node Pro show in iCUE?

Helios18 01-13-2019 08:36 PM

No it does not

DevBiker 01-13-2019 09:07 PM

Can you do a screen shot of the iCUE configuration screen?

Helios18 01-13-2019 11:56 PM

1 Attachment(s)
I'm assuming this is what you mean..?

Helios18 01-19-2019 02:24 AM

1 Attachment(s)
I read some other corsair forums and downloaded USBDView and this is what it looks like. Are each of those 1b1c items corsair devices? I'm still missing my case rgb and rgb cans in iCUE, but my corsair cpu cooler, keyboard, and mouse all show up in iCUE.

Exsosus 07-09-2019 06:42 PM

Hi, everyone. After 3-months + with Corsair support the answer is simple.

Step 1: Run Winver in Run command.
Step 2: Uninstall iCue complete and if you have Link installed, that too.
Step 3: Restart Windows. (Yes I know its windows 10 but this is hardware related. Do it).
Step 4: Install Corsair Link 4.9.9.3 for Windows version 1809 OS Build 17753.557 or later.
Step 5: If you want iCue for your keyboard RGB and other accessories install that now.

You should have all devices showing in Corsair Link!

Enjoy.


All times are GMT -4. The time now is 12:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.