The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Solid State Drives (SSD) (https://forum.corsair.com/forums/forumdisplay.php?f=188)
-   -   SSD SMART info shows 100C on Linux (https://forum.corsair.com/forums/showthread.php?t=164513)

Akronix 12-26-2016 04:09 PM

SSD SMART info shows 100C on Linux
 
1 Attachment(s)
Hi!

I've recently bought a Corsair Force LE SSD 240GB drive. I've installed it on my PC and, before to insert anything into it, checked for errors and done some benchmark test. Everything seems to be OK, but the temperature. SMART data says that it is always at 100C (212F); which is, of course, too much.
This is on Linux, because I've tried booting with windows 8 and it showed a more reasonable temp (30 or so).

I guess this is related to "Interpreting SMART Data on Corsair SSDs". So I should not panic; But, is there any option to get the real temperature info? maybe somehow upgrading the firmware (must be a for-Linux solution)?

I attach a screen-shot with the temperature data I get displayed.

Toasted 12-28-2016 08:10 AM

Have you tried using a different application to see the SMART values?

Akronix 12-28-2016 08:32 AM

I've used psensor indicator (psensor package) and SMART info displayed by gnome-disk-utility, both shown in the screenshot I attached.
sensors from lm-sensors doesn't show anything relevant.

I'll try some other though.

Technobeard 12-28-2016 10:53 AM

I'd suggest contacting our support team, but most likely that series just doesn't have a temperature sensor (not all do).

Akronix 12-29-2016 07:10 PM

I've installed hddtemp package and it shows something more realistic:
> $ sudo hddtemp /dev/sda
/dev/sda: Corsair Force LE SSD: 30C


But It never moves from that 30C, even under a hard reading benchmark; so I'm still not sure if that's actual data.

Toasted 12-30-2016 06:56 AM

As Technobeard has mentioned, not all SSDs have a temperature sensor in them, But i recall seeing the value change when temperatures are really hot. e.g. A SSD installed inside a laptop.

Akronix 12-30-2016 07:28 AM

Yeah, in my laptop I have a Samsung EVO SSD drive and it's usually at 46C (psensors info), but It reaches 50C under the same benchmark I did in the Corsair one.
Btw, curiously hddtemp says that there's no sensor for the samsung one, meanwhile psensors and smart data (gnome-disk-utility) looks to display a rather accurate temperature.

These different outputs and behaviours are confusing. In case Corsair SSD doesn't have any sensors, why it doesn't just states that instead of showing 100C? something like NO DATA or, at least, 0C?
Seeing 100 C is awkward ('-_-)


All times are GMT -4. The time now is 06:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.