The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   Glaive Double Click Issue (https://forum.corsair.com/forums/showthread.php?t=171481)

Jellal 10-01-2017 10:36 PM

Glaive Double Click Issue
 
Hello, my glaive seems to be one of the many with a double click issue, where the mouse will click twice instead of once. I have installed the updated firmware for the glaive but this just makes it so sometimes my clicks aren't registered at all. Will there be another update to completely resolve this issue? Or is it truly hardware related and I will need to RMA? I am not comfortable with bending my switches.

terabyte 10-02-2017 10:11 AM

Which FW version are you using exactly? I believe there were 2 different beta FW updates for the double click issue.

Corsair Nick 10-02-2017 02:51 PM

Try flashing the mouse with the firmware file in the attached in the following link, and let us know if the issue continues.

http://forum.corsair.com/v3/showpost...8&postcount=11

pawlakbest 10-04-2017 06:43 PM

After flashing it's harder to reproduce the problem just by clicking left mouse button, that is true for me. But it's easy when I press and hold the left mouse button. Then it appears like it was clicking all the time(pressing and holding should be equal to single click but it does click, click, click...) :( It's my 2nd mouse after 1st was RMA due to this problem but in far worse scale. It's my first Corsair product, I also considered buying K70 LUX keyboard to have a combo and cause everyone was recommending me it but now i have my doubts.

Taako. 10-05-2017 11:33 AM

Hello,

Also experiencing something similar. It randomly double clicks or sometimes it just stops registering the click when pressing and holding the left mouse button.
This is most noticebly in shooter games. Sometimes it stops in the middle of a spray, or only register the very first miliseconds of the "hold click" causing it to only shoot the first bullet.
Firmware update is 1.04

I've had the mouse since late August and only this past week it has started this "behaviour".

It's been very random so it's hard to reproduce.

Should I try that firmware update from the post above?

Not sure if I should RMA the mouse because the problem is not that frequent and the store will mostlikely not detect it...


All times are GMT -4. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.