The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   iCUE Software (https://forum.corsair.com/forums/forumdisplay.php?f=280)
-   -   iCUE (MacOS) Now Available as Open Beta! (https://forum.corsair.com/forums/showthread.php?t=182942)

elmirage 05-09-2019 11:23 AM

this works fine on mojave/macbook pro 2015/k95 platinum.
this does NOT work on mojave/macpro late 2013/k95 platinum (device not recognized).

any clue? many thanks

manax 05-10-2019 02:43 PM

Remap Control Buttons like CMD
 
Hi James! Awesome software.

Unfortunately, I think there is a bug with the SW profiles for a keyboard (I'm using the K95).
My goal is to remap my keys to a standard Mac layout. The remapping seems not to work for any key on a SW profile.

My approach: SW Profile > Add action > Remap Keystroke > ALT key chosen on the layout > "Type Key" CMD. Nothing changes.
Same goes for changing the "1" to an "A" or something random.

Most interestingly, it works on Hardware profiles!

Any advice?

PS: One needs to use a trick to map all four control keys on a HW profile, but then it works fine. Just save that action to the library to be able to select the last key.

armanarifi 05-13-2019 01:36 PM

RGB Glaive Malfunction
 
Dear James,

Ive had the mouse for 3 months now. It was working fine even though the iCUE for Mac doesn't recognise it.

I updated the firmware on a PC and since then when I plug it on the Mac (works fine on windows though) I have malfunction. I can move the cursor. But the buttons stopped working.

Can you help me out?

MrOliverYT 05-15-2019 12:41 AM

Hello, why does it show “no devices detected” in iCUE even when I plug in my m65 pro ??


Thanks!!!!

MrOliverYT 05-15-2019 12:42 AM

Hi why does it say “no devices detected “ when I plug in my m65 pro mice???

sleither 05-21-2019 08:43 AM

RGB Strafe - RGB0018
 
Can someone advise me to why my RGB keyboard is not working on this Beta? I did put it on a Windows computer and updated the Firmware to 3.08. When I connect it to my Macbook Pro using macOS Mojave – 10.14, it will not recognize it? I was using CBK and wanted to try this Beta application. I did uninstall the CBK and rebooted. Installed the latest Beta version and rebooted again. It comes up with "No Device Connected". It does say that the RGB keyboards are supported. Can some please let me know what I can do to make it work? Thxs.

Matthijs B 05-21-2019 11:53 AM

I have the Harpoon RGB, wired ,but iCUE isn't detecting it. I was wondering if anyone knew a fix?

sleither 05-21-2019 06:08 PM

Quote:

Originally Posted by sleither (Post 1005238)
Can someone advise me to why my RGB keyboard is not working on this Beta? I did put it on a Windows computer and updated the Firmware to 3.08. When I connect it to my Macbook Pro using macOS Mojave – 10.14, it will not recognize it? I was using CBK and wanted to try this Beta application. I did uninstall the CBK and rebooted. Installed the latest Beta version and rebooted again. It comes up with "No Device Connected". It does say that the RGB keyboards are supported. Can some please let me know what I can do to make it work? Thxs.

Just updated the iCUE application to 3.16.56 and still getting "No Device detected!" message.. Please help.

noahboa 05-21-2019 08:40 PM

Quote:

Originally Posted by sleither (Post 1005292)
Just updated the iCUE application to 3.16.56 and still getting "No Device detected!" message.. Please help.

Hello, I installed CBK next before iCue was released for macOS. First thing I had to do was to remove the CBK files from Application Support, Launch Agents, etc. Another use explained earlier in the thread how to get iCue to work because any trace of CBK Next could mess it up. Another thing you may have to do is run windows on your computer to update the firmware of your device (assuming you have never been able to connect it). If you had it previously connected you may want to check if the device is actually updated via the iCue firmware on macOS.

noahboa 05-21-2019 08:41 PM

Does anyone know how long we should expect to wait for the next update (to fix the audio plugin etc.)?

BlackScorpion 05-22-2019 07:47 PM

The latest update has been released Version 3.16.56

sleither 05-24-2019 08:16 AM

Quote:

Originally Posted by noahboa (Post 1005307)
Hello, I installed CBK next before iCue was released for macOS. First thing I had to do was to remove the CBK files from Application Support, Launch Agents, etc. Another use explained earlier in the thread how to get iCue to work because any trace of CBK Next could mess it up. Another thing you may have to do is run windows on your computer to update the firmware of your device (assuming you have never been able to connect it). If you had it previously connected you may want to check if the device is actually updated via the iCue firmware on macOS.

I did uninstall CBK from every file location on my MAC before installing iCue. I did put it on a Windows computer and updated the Firmware to 3.08.*iCUE application to 3.16.56 and still getting "No Device detected!" message..

sleither 05-28-2019 11:03 AM

Quote:

Originally Posted by sleither (Post 1005573)
I did uninstall CBK from every file location on my MAC before installing iCue. I did put it on a Windows computer and updated the Firmware to 3.08.*iCUE application to 3.16.56 and still getting "No Device detected!" message..

Anyone? There has to be a fix out there, no?

Mondrayy 05-28-2019 01:07 PM

I've noticed that after updating iCUE to latest 3.16 my Dark Core RGB lighting effects are freezing randomly after waking up Mac. Nothing hugely annoying but still seems to be a bug. Have noticed it 3 times now in 2 days.

Kooky_Bottomry 05-28-2019 07:47 PM

me too, I just bought that keyboard recently i tried reading through reddit for how to fix that problem but none of them works.


All times are GMT -4. The time now is 10:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.