The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   Corsair Glaive side buttons have a delay (https://forum.corsair.com/forums/showthread.php?t=184213)

Dodger28 01-04-2019 09:35 PM

Corsair Glaive side buttons have a delay
 
So i've recently bought a new mouse the corsair glaive. I like this mouse a lot but i have a little problem. In any game let's say overwatch i have my abilities registered to my side buttons. This i just applied because of my previous mouse where it was so fun to use. But with the corsair glaive i have a pretty big delay. sometimes when i press it it just does the thing that it has to do but at a certain point i press it, it waits like 2 to 3 seconds and then it does it and thats a pretty big problem u know. also when i press it when the ability is not ready it looks like the mouse saves it and when the ability is ready it just reminds itself that i pressed it before and does it automatically without me even wanting to press it. i hope one of u guys can fix this. a helping hand would be usefull

Corsair Hotpot 01-07-2019 03:21 PM

Do you have iCUE installed? If so did you use a macro or key rebind to any of the side buttons? If you didn't, I'd try a different USB port as it could be a polling issue or change the polling rate in iCUE device settings.


All times are GMT -4. The time now is 10:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.