The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Corsair Link Crashing (https://forum.corsair.com/forums/showthread.php?t=185750)

Ravenbear 02-25-2019 06:53 PM

Corsair Link Crashing
 
I know this has been brought up before, Link 4 (lastest ver.), when I start I get the window just the window red background it displays nothing and after a few seconds, it crashes. I have uninstalled it and still the same. It was working and the only thing that has changed is my GPU. Has anyone found a fix for this? It seems to be an ongoing issue and I have not found any post with a solution. Thank you for taking the time to read this. BTW there is no error msg.

Shaitan 08-21-2019 09:32 PM

I have the exact same issue. Funny how there is still no fix for this. I have been with this product since it was called COOLiT. Corsair bought them out apparently. I`d really hate to have to find another cooling solution, but your post is 6 months old. Aaaaah well.

DevBiker 08-22-2019 12:21 AM

Quote:

Originally Posted by Shaitan (Post 1015370)
I have the exact same issue. Funny how there is still no fix for this. I have been with this product since it was called COOLiT. Corsair bought them out apparently. I`d really hate to have to find another cooling solution, but your post is 6 months old. Aaaaah well.

So ... CoolIT is an OEM for liquid cooling pumps and was the OEM of some of Corsair's coolers.

Corsair never bought them. They've used them and Asetek.

As for this issue - it's most likely due to a GPU driver issue so it's not something that Corsair can fix. But Link is - and has been for, like, a year now - end of life.

Shaitan 08-22-2019 12:40 AM

I haven t changed anything actually. The only thing I did was upgrade to the latest Corsair Link 4. Now when I open Corsair Link 4, all you see is the applet. It doesn`t see any of my hardware anymore since this morning.

So it seems that Corsair no longer supports the H80i Vers. 2 I guess. So I`ll check around for a similar cooling product..... from another maker.

DevBiker 08-22-2019 07:41 AM

Quote:

Originally Posted by Shaitan (Post 1015378)
I haven t changed anything actually. The only thing I did was upgrade to the latest Corsair Link 4. Now when I open Corsair Link 4, all you see is the applet. It doesn`t see any of my hardware anymore since this morning.

So it seems that Corsair no longer supports the H80i Vers. 2 I guess. So I`ll check around for a similar cooling product..... from another maker.

No, that is not the case and I don't know why you have that impression. It is supported and will show up in iCUE. It's Link that is end of life.

shadez 08-22-2019 02:47 PM

Glad to know that I wasn't the only one. Spotted some DLL Error and tried Re-installing the LINK 4. But it keeps getting stuck at .NET Framework requirement thing. Not sure which software I should use for H100i v2.

Shaitan 08-26-2019 10:50 AM

Link is at the end of it`s life? Corsair Link 4 was awesome when it worked. iCue. Yes it does see my H80i vers. 2. But it is nowhere near as good looking or robust an app for my cooler as Corsair Link was. Gotta be honest. It looks half baked and not ready for prime time. Now that I have ICue running, I would rather have a working Corsair Link than ICue. Corsair Link was amazing incomparison, and it will be/is missed greatly.


All times are GMT -4. The time now is 01:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.