The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   AX860i not seen by CL (https://forum.corsair.com/forums/showthread.php?t=171315)

Schar07 09-23-2017 08:36 AM

AX860i not seen by CL
 
3 Attachment(s)
I know it is a common headache, but i tried everything. AX860i does not show up in latest CL.

W7 x64 + i7 4770k + Asus M6F Z87.
H80i + AX860i, PS is connected through H80i block.
SIVx64 sees both fine.
Device Manager shows no Corsair Integrated USB bridge (HID/USB) devices, but it shows both VID_1B1CXXXXXXX USB Input and HID-compliant devices as generic/unbranded and OK.
In Control Panel Programs and Features i have both Corsair LINK 4 and Windows Driver Package - Corsair Components, Inc. (SIUSBXP) USB (07/14/2010 3.3) items.

PS was seen with older releases, probably up to 1y ago, i did not notice exactly when it disappeared. Sometimes updating CL was breaking things up but uninstall + manual cleaning + reinstall worked fine...now doesn't.

I already removed CL with full manual cleaning of folders and registry keys - including those requiring SYSTEM permissions to be deleted.

I have seen the AXi PSU Drivers red-rey was posting, but they don't install through the INF file right click neither through Device Manager, as i have no yellow keys to apply them neither does the HW scan find any new devices for the AXi. How can i load them?

Any further ideas before throwing this crappy software into the bin?

Thanks!

red-ray 09-23-2017 09:16 AM

SIV reports your AX860i so CL4 should !
 
As your AX860i is connected via the H80i C-Link port then all the posts I made about the SIUSBXP driver don't apply. This driver is only used when the Corsair Link AXi PSU USB Dongle is used to connect AXi PSUs.

Quote:

Originally Posted by Schar07 (Post 920969)

SIV reports your AX860i so the hardware is fine and CL4 should also report it :nodding:, but I have no real idea as to why CL4:!oops: fails. I suggest you log a call via https://support.corsair.com/ and ask Corsair to fix their software :rant2:, remember to upload your original invoice.

As no fans are connected to the H80i I guess you must be using the motherboard to control them, are you? Assuming so I guess you have no real need to use CL4.

Looking at your http://forum.corsair.com/forums/showthread.php?p=903638 post my guess is that things went wonky in CL 4.7.0.77. I would be inclined to try CL 4.6.0.86 with the CPUIDSDK.dll from CL 4.8.3.8.

Schar07 09-24-2017 04:00 PM

Thanks RR,

Ticket opened:shootme:

Yes, H80i two fans are connected to mobo CPU headers and controlled by Asus AI Suite 3 Fan Xpert 2. BTW, i also closed AI SUite 3 and retested LINK, but no PSU yet.

Reason to use link was mainly to see wattage absorption and trending more easily. Plus, i hate the idea that Corsair software doesn't work with 2 of their own pieces of HW... come on!:nono:

And,,,well, thanks, i forgot i made the analysis and post in May! Actually i do confirm it. And thanks, i'll give CPUIDSDK.dll trick a shot.

Thank you and regards

Schar07 09-24-2017 04:39 PM

1 Attachment(s)
RR,

v4.6.0.86 with CPUIDSDK x86 and x64 DLLs from 4.8.3.8 is almost working!

Only two 220mm slow speed chassis fans #1 and #3 are off (actually they were shutdown while screenshooting - temp controlled by Asus AI Suite), but i can now see MOBO + CPU + SSDs + GPUs + DRAMs + H80i + AX860i!

red-ray 09-25-2017 04:16 AM

Don't use SIV if you have ASUS AI Suite active!
 
Quote:

Originally Posted by Schar07 (Post 921048)
temp controlled by Asus AI Suite

Don't use SIV if you have ASUS AI Suite active!, see http://forum.corsair.com/forums/showthread.php?t=141037

There are many posts about ASUS AI Suite + CL4 "not getting along" and I advise against trying to do this.

Schar07 09-27-2017 05:45 PM

OK, actually exiting both AI Suite and AIDA64 shows correct chassis fans values in LINK. I'll decide what to leverage moving fwd, but thanks for the Dll trick.

PS: no news from Corsair yet


All times are GMT -4. The time now is 04:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.