The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Corsair Link (https://forum.corsair.com/forums/forumdisplay.php?f=209)
-   -   Corsair Link 4 crashing when I click on it's icon and try to restart it (https://forum.corsair.com/forums/showthread.php?t=168233)

ocrnon 05-31-2017 05:53 AM

Corsair Link 4 crashing when I click on it's icon and try to restart it
 
Restarting my pc or uninstalling Link doesn't fix this. I reinstalled steam to fix the same crashing issue some of my games were having and that fixed both the problems. This only started happening two to three days ago. The Link 4 service is still running in my task manager, I just can't monitor temps or change fan speeds because Link won't boot.

Greybeard 06-01-2017 05:32 PM

Are you using the late version of C link? it should be 4.7

When you uninstall C link, make sure to uninstall the USB driver before you do a clean install. Also, try running C link as admin and see if you get the same result. Make sure to do all Windows update including your mobo USB drivers before doing a clean install.

JadSeelen 06-04-2017 12:08 PM

I informed Corsair of this a month ago. Still no solution in sight and they won't reply to my ticket. I thinking I'm thinking I should of bought a NZXT or Swiftech AIO.

quadlatte 06-08-2017 06:27 PM

i was having the same issue, uninstalled CL and the driver still no change, after several failed attempts i disabled fast startup in the windows power. all issues solved, link now runs stable and detects all my hardware. had a few other wierd things happening with other programs also and they also cleared up after i disabled fast statup. thanks MS for another default "feature" that breaks stuff


All times are GMT -4. The time now is 06:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.