The Corsair User Forums

The Corsair User Forums (
-   Audio (
-   -   HS70 Microphone not working (

Rob86 11-28-2018 08:50 PM

HS70 Microphone not working
Hello everyone.

I noticed a few threads mentioning mic problems with their HS70 wireless headsets but while going through them none of the proposed solutions seem to work. You see I have the mic on, everything is plugged in right and the mic is registered by Windows 10 as a device but I am getting nothing when I speak. Checked privacy settings to see if that was the problem but my mic is enabled for all the listed applications. Not sure what to try next to solve the problem. Any ideas?

Corsair Mint 11-29-2018 03:52 PM

Hi Rob86, is the mic set as the default device + default communications device ?

Rob86 11-29-2018 06:16 PM

Yes, the microphone is listed as the default device for output. I believe I may have stumbled upon a solution based on forum member Corsair Calico Jack's recommendation to another forum member concerning dropped connection problems with the headset in this thread. Here is what Calico Jack recommended:

Originally Posted by Corsair Calico Jack (Post 982240)
Please go to CONTROL PANEL / HARDWARE AND SOUND / POWER OPTIONS and then click on CHANGE PLAN SETTINGS (for your current default power plan). After that click on CHANGE ADVANCED POWER SETTINGS.

When new window opens, scroll down the list a bit until you hit USB SETTINGS. Click little square with plus in it, and then click another little square with plus next to USB SELECTIVE SUSPEND SETTING. Check the state of it, and make sure it's set to DISABLED.

I thought to try it and my microphone started working as expected. I have yet to see if the mic continues to work as normal but it seems to have been an issue with the USB connection.

robotic212 11-29-2018 07:35 PM

I have the same problem, I just got the headset hs70. I installed drivers and software cui etc. fully charged, connected everything, mic, usb etc.
I set all output and input to be this headset. im not muted, sound is on. I changed the power settings as you suggested. I tried anything I could find info about so far and still nothing. The mic from the hs70 I got doesn't work at all it seems :/ any tips or did I get a faulty item?

robotic212 11-30-2018 07:23 PM

it magically worked today when i woke up. no idea how

Rob86 11-30-2018 08:56 PM

Well, at least it works now. Still strange why the microphones on these headsets were not working initially for either of us. I wonder if this is a common problem or an outlier.

maimai 12-26-2018 02:16 AM

I was wondering for quite some time why the mic didn't work, and ended up reading all the forum posts, getting already a bit desperate. My problem in the end was that I had not pushed the mic's jack far enough in the headphone. So that's also worth a try if you are reading this forum now looking for solutions. :)

Aple13 07-20-2019 05:04 PM

bought these yesterday and everything seemed fine, but today i was on discord with my friend and the mic on the headset stopped working. i tried to do everything but i couldnt get it to work and decided to restart my computer, it worked for 5 minutes and boom, its not working anymore.

i've always had issues with corsair products, i dont understand how.

CCGamer5567 08-13-2019 08:10 AM

For anyone who keeps finding this topic with the same problem.

I recently bought a corsair HS70 Wireless.

Simply unplug and replug the usb device. This is what solved the problem for me.


All times are GMT -4. The time now is 09:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.