The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 02-20-2020, 04:34 PM
Dcm210 Dcm210 is offline
Registered User
Dcm210's PC Specs
 
Join Date: Feb 2020
Posts: 1
POST ID # = 1035617
Dcm210 Reputation: 10
Default PC doesn't shut down completely, help?

So I've upgraded to a Corsair K95 RGB Platinum Mechanical Gaming Keyboard
and a Corsair MM800 Polaris RGB Mouse Pad. Now when I shut down Windows 10,the fans are still going.

I've had to turn PSU off to full have my computer off. Also if I restart,it just kinda does the same thing. I have to hit the reset button to restart it. I'm using the latest version of Corsair iCUE. I really wanna like this new hardware and keep using it.

I'm still running Windows 10 64bit version 1903. I haven't updated Windows 10 to the next bit version considering there is file issues going on.
Reply With Quote
  #2  
Old 02-21-2020, 09:30 PM
russk russk is offline
Registered User
russk's PC Specs
 
Join Date: Feb 2020
Posts: 8
POST ID # = 1035684
russk Reputation: 10
Default

Not exactly an expert on this, but I have run into issues on occasion where a PC would get into this weird state. Hopefully some of these tips are helpful. These are all with the assumption that this issue is happening on every shut down now, as opposed to a sporadic issue.

First, if you think the issue was brought on by iCUE or the new keyboard and mouse pad, the first thing you can do is use the computer without them to see if the issue persists. Easiest thing first is just swap in a different keyboard and d/c the mouse pad. If the issue still persists, then go ahead and uninstall iCUE and see if the issue still persists. This will at least help you identify if any of these three are truly contributing to the issue.

There's another thing windows 10 does that can make shutdowns look stuck like this, but it doesn't impact restarts - so I'm skeptical this would be the solution for you. Press the start menu and start typing "powercfg.cpl" and hit enter. On the left hand side, there is "Choose what the power buttons do" and in there hit the option to "Change settings that are currently unavailable." There is a setting called "Turn on fast startup (recommended)" that I actually recommend disabling. When it's enabled, it makes the shutdown process take longer so that the start up process can be quicker (pre-caches some things). Regardless, like I said this only impacts Shut Down, not Restart, so it's likely not your issue. Also, if you disable this option (I need to for other reasons) be mindful that certain Windows Updates will automatically re-enable it on you.

Lastly, I'm not too familiar with the newer UEFI or AMD platforms. However, in systems I've used in the BIOS there are usually ACPI configurations. My understanding is this is the interface that OSes use to talk to the motherboard to actually put it into different power states. You hardly ever need to play with these settings, but may need to check them since it may not be working correctly. Check your manual (or Google) for your motherboard and see if there are any settings you may need to adjust. In my experience, I've never had an issue with Windows requiring such adjustments, but certain Linux OSes have been particular about such configs - YMMV. Semi related, you can also check your mobo mfr's website and ensure you have all the latest drivers.
Reply With Quote
Reply

Tags
corsair, k95, mousepad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.