The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 09-02-2020, 02:43 PM
trevorplatt trevorplatt is offline
Registered User
 
Join Date: Sep 2020
Posts: 2
POST ID # = 1059634
trevorplatt Reputation: 10
Unhappy Please Help Harpoon Wireless RGB

Hi all,

I hope you can help.

I bought a Harpoon Wireless RGB mouse, plugged in the receiver and it was working fine. I downloaded the iCUE software to adjust the constantly changing logo colours and now the cursor doesn't move and the buttons do nothing. It's as if the mouse and receiver no longer talk to each other.

When I first installed the software it asked me to plug the mouse in for an update, I did that and waited until it finished, then unplugged it and everything stopped working. It works when I plug it in, but obviously I bought a wireless mouse for a reason.

I tried resetting the mouse as per the Corsair website, that did nothing. I've tried rebooting the PC, plugging the receiver into a different port and I've tried uninstalling the software. Still nothing.

Any advise would be very much appreciated.
Reply With Quote


  #2  
Old 09-02-2020, 04:55 PM
Corsair Albert's Avatar
Corsair Albert Corsair Albert is offline
Corsair Employee
 
Join Date: Jul 2020
Posts: 143
POST ID # = 1059657
Corsair Albert Reputation: 10
Default

Hi trevorplatt,

Have you tried re-pairing the HARPOON with its wireless dongle?
  1. Make sure the wireless dongle of your mouse is connected to your PC.
  2. Open iCUE.
  3. Click SETTINGS.
  4. Click the Initiate button next to “USB Wireless Receiver Pairing.”
  5. Turn off the wireless mouse you want to pair.
  6. Make sure that the switch on the bottom of your mouse is set to 2.4 GHz.
  7. Hold down the profile button that’s located directly under the mouse wheel.
  8. Turn on the mouse.
  9. You should see a PAIRING SUCCESSFUL! message when the mouse is paired.


Reply With Quote


  #3  
Old 09-03-2020, 12:09 PM
trevorplatt trevorplatt is offline
Registered User
 
Join Date: Sep 2020
Posts: 2
POST ID # = 1059763
trevorplatt Reputation: 10
Default

YES! You magnificent beast

Thank you.

First time I've ever spent more than £10 on a mouse and I thought it was a dud.

Why didn't the software tell me to do that?
I did click the initiate button before and it told me to plug in the mouse - it seemed to pair and then when I unplugged it it obviously stopped working again

Anyway, thanks again. Your assistance is gratefully received.
Reply With Quote


Reply

Tags
broken, harpoon, mouse, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.