The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 10-05-2019, 11:59 AM
dav461 dav461 is offline
Registered User
dav461's PC Specs
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1020347
dav461 Reputation: 10
Question Virtuoso RGB - no sound in right ear.

Hello everyone,
I am new to corsair audio products, that is my first wireless headset.
So i received headset today, after I plugged it to my PC via USB mode, i found out that right ear doesn't play sound at all. I have checked all settings- all fine. Tried 3.5 & wireless modes - same, not working. I plugged my sennheiser all good, can hear in both ears.
Any tips where shall i look to? or its 100% just broken headset that needs to be returned? Thank you in advance

P.S. tried with iphone - same :(

Last edited by dav461; 10-05-2019 at 12:34 PM.
Reply With Quote


  #2  
Old 10-07-2019, 06:39 AM
jpdsc jpdsc is offline
Registered User
 
Join Date: Jan 2016
Posts: 29
POST ID # = 1020522
jpdsc Reputation: 10
Default

I would return it as a DOA (Dead on arrival).
Reply With Quote


  #3  
Old 10-07-2019, 01:05 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 941
POST ID # = 1020574
Corsair Nick Reputation: 39
Default

Sounds like you might have received a defective you since you tried multiple devices and connections. What I'd like you to do is submit a request direct with us so we can get the unit back. After you submit the ticket, go ahead and PM me the ticket number so I can work with Technical Support to get the unit shipped back.

https://support.corsair.com/
Reply With Quote


  #4  
Old 10-07-2019, 02:26 PM
dav461 dav461 is offline
Registered User
dav461's PC Specs
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1020584
dav461 Reputation: 10
Default

Quote:
Originally Posted by Corsair Nick View Post
Sounds like you might have received a defective you since you tried multiple devices and connections. What I'd like you to do is submit a request direct with us so we can get the unit back. After you submit the ticket, go ahead and PM me the ticket number so I can work with Technical Support to get the unit shipped back.

https://support.corsair.com/
Greetings Nick,
It is a bit different. I bought them in German online shop and they were delivered to my friend in Berlin, he then brought them to me to Russia. Now, I am confused how to ship and return them. I found out that there are no Corsair Service Centers in Russia. I would appreciate any tips you give to me please.
Shall I still do the way you told me? It is my first time returning items in whole life
Reply With Quote


  #5  
Old 10-07-2019, 05:21 PM
TWP TWP is offline
Registered User
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1020604
TWP Reputation: 10
Default

@dav461

Your situation may be different, but as a suggestion, I had a brief instance where the Virtuoso was only playing sound out of one side in USB mode. I switched it to wireless mode and it then started working properly. After that, I switch it back to USB mode and both sides then worked.
Reply With Quote


  #6  
Old 10-07-2019, 05:29 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 941
POST ID # = 1020606
Corsair Nick Reputation: 39
Default

No worries, go ahead and create the ticket, and send it to me. I already talked with one of our Tech Support agents about your situation, and he'll discuss options with you in your ticket. They are more familiar with our shipping and exchange policies for your unique situation.
Reply With Quote


  #7  
Old 10-08-2019, 05:58 AM
dav461 dav461 is offline
Registered User
dav461's PC Specs
 
Join Date: Oct 2019
Posts: 4
POST ID # = 1020655
dav461 Reputation: 10
Default

Quote:
Originally Posted by TWP View Post
@dav461

Your situation may be different, but as a suggestion, I had a brief instance where the Virtuoso was only playing sound out of one side in USB mode. I switched it to wireless mode and it then started working properly. After that, I switch it back to USB mode and both sides then worked.
I tried all modes, all same, even with mobile device

Quote:
Originally Posted by Corsair Nick View Post
No worries, go ahead and create the ticket, and send it to me. I already talked with one of our Tech Support agents about your situation, and he'll discuss options with you in your ticket. They are more familiar with our shipping and exchange policies for your unique situation.
Nick I have messaged you number
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.