The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

 
 
Thread Tools Search this Thread Rating: Thread Rating: 10 votes, 5.00 average. Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-12-2012, 04:44 PM
MobiusTrobius MobiusTrobius is offline
Registered User
 
Join Date: Jan 2012
Posts: 7
POST ID # = 554229
MobiusTrobius Reputation: 10
Default 1500 Headset Driver Issues

So, I grabbed a V1500 for ze holidays and have been having issues installing the specialized drivers provided on the Corsair web page. When I insert the headset into a USB 2.0 port on my rig, the Windows drivers install automatically and I'm able to use the headset at a barebones level as I would any other plug-and-play device. Every attempt to install the 1.1 driver .exe leads me to a screen with the only option of "uninstall".

I've been through tech support and tried a whole myriad of different solutions (rebooting, uninstalling the headset and drivers through both add/remove programs and device manager, preventing windows from auto-installing devices, trying again rebooting some more, etc.) and none have seemed to work. The headset itself is perfectly functional, and I installed both it and the custom drivers on my ASUS netbook within a matter of minutes.

I'm at a loss for what to do as I'm unable to unlock the specialized functions that the Corsair drivers would enable. I'm totally willing to provide info about my PC to engineer a solution. Any suggestions?

Last edited by MobiusTrobius; 01-12-2012 at 04:47 PM.
Reply With Quote


 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.