The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-09-2017, 12:17 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929718
Dominator01 Reputation: 10
Default 4.9.3.25 issue installing

Trying to update Corsair Link from 4.9.2.27 to 4.9.3.25 and there is a error where the program has shut down or something before installing. I think alot of people are having issues installing the new version because of it, anybody?
Reply With Quote


  #2  
Old 12-09-2017, 12:25 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,828
POST ID # = 929719
DevBiker Reputation: 88
Default

Can you provide a little more detail on the error? Was there any message?
Did you try to install from within Link or did you download and run separately?
Finally ... did you try uninstalling the old version and then installing the new version?
Reply With Quote


  #3  
Old 12-09-2017, 01:02 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929725
Dominator01 Reputation: 10
Default

I actually found out about it from after loading Corsair Link and it prompted me that there was an update, then i got that error. So then i tried downloading it and it would do the same exact thing. The error is something about the program did not close properly or something. I'll show you a screen shot, but i think alot of people are having that issue with this new update, something is wrong with it.
Reply With Quote


  #4  
Old 12-09-2017, 01:07 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929726
Dominator01 Reputation: 10
Default

Okay, i just got a screen shot of it, here...

https://imgur.com/a/WvPh7
Reply With Quote


  #5  
Old 12-09-2017, 01:23 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,828
POST ID # = 929727
DevBiker Reputation: 88
Default

Well, it was just released and you're the first (and only, so far) to report it, so it's a little early to say that "a lot of people are having that issue".
That said, it's still concerning.
So ... a couple of things.
First, what version are you upgrading from?
Second, can you look in Event Log to see if there is an error in there? In particular, can you look for something at the time of the crash with ".NET Runtime" as the source. This will likely have a stack trace, which will give Corsair Dustin & The Dev Team an idea of where the problem may be.
Last, but not least, let's see if we can get the install to work. Can you download it separately, close Link and then install? If not, can you uninstall the previous version and then install?
Reply With Quote


  #6  
Old 12-09-2017, 01:27 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929728
Dominator01 Reputation: 10
Default

I'm running version 4.9.2.27 and i have already closed down the app and tried running the downloaded install one with the same issue.

Application: Corsair LINK Installer v4.9.3.25.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000096, exception address 641081D1
Reply With Quote


  #7  
Old 12-09-2017, 01:28 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929729
Dominator01 Reputation: 10
Default

Faulting application name: Corsair LINK Installer v4.9.3.25.exe, version: 4.9.3.25, time stamp: 0x57570038
Faulting module name: d3d9.dll, version: 10.0.16299.98, time stamp: 0xe2fbf0fc
Exception code: 0xc0000096
Fault offset: 0x000481d1
Faulting process id: 0x2520
Faulting application start time: 0x01d370ab559c9f2e
Faulting application path: C:\Users\iSEVEN\AppData\Local\Temp\{1431A646-1215-4CF5-B0B2-2F07A2CF270B}\.cr\Corsair LINK Installer v4.9.3.25.exe
Faulting module path: C:\Windows\SYSTEM32\d3d9.dll
Report Id: 55b2ce62-1b9b-421a-bb4f-0664de3f83fb
Faulting package full name:
Faulting package-relative application ID:
Reply With Quote


  #8  
Old 12-09-2017, 01:29 AM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929731
Dominator01 Reputation: 10
Default

Honestly, i have upgraded or done a clean install of this utility for almost a year now and this is the first time ever having this kind of issue.
Reply With Quote


  #9  
Old 12-09-2017, 01:41 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,828
POST ID # = 929733
DevBiker Reputation: 88
Default

OK ... we do have events. Those look like the "Application Error" events. Those are of limited use, to be honest. Look for another one, right by the Application Error, with a source of ".NET Runtime". Then look at the "Exception Info" in the General tab. It'll look like this:
Reply With Quote


  #10  
Old 12-09-2017, 01:43 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,828
POST ID # = 929734
DevBiker Reputation: 88
Default

Quote:
Originally Posted by Dominator01 View Post
Honestly, i have upgraded or done a clean install of this utility for almost a year now and this is the first time ever having this kind of issue.
Yeah, the install has been pretty solid. No simple feat, by the way.
FYI: I have three systems with Link. On one, I did a manual uninstall/reinstall. I had planned this (for specific reasons). On the other two, the normal upgrade path worked like a charm.
Reply With Quote


  #11  
Old 12-09-2017, 04:19 AM
DeadxWreckoning DeadxWreckoning is offline
Registered User
DeadxWreckoning's PC Specs
 
Join Date: Aug 2017
Posts: 20
POST ID # = 929746
DeadxWreckoning Reputation: 10
Default

I had this same issue. Link installer kept crashing every time I went to install the update, be it thru the old Link version or by downloading the standalone installer. I finally got it to work by closing everything in my app tray - which included Corsair CUE. Can't say for sure if CUE caused it but it's conflicted with Link in the past, recently too. Try closing CUE and other apps in your tray and trying it.
Reply With Quote


  #12  
Old 12-09-2017, 04:21 AM
OctavianH OctavianH is offline
Registered User
OctavianH's PC Specs
 
Join Date: Oct 2017
Location: Brasov
Posts: 4
POST ID # = 929747
OctavianH Reputation: 10
Default

I have the same problem, and even if I try to uninstall (manually or with Revo Uninstaller) the 4.9.2.27 version I receive an error. So basically I cannot uninstall or install the new one over this existing version.
Reply With Quote


  #13  
Old 12-09-2017, 04:24 AM
DeadxWreckoning DeadxWreckoning is offline
Registered User
DeadxWreckoning's PC Specs
 
Join Date: Aug 2017
Posts: 20
POST ID # = 929749
DeadxWreckoning Reputation: 10
Default

Quote:
Originally Posted by OctavianH View Post
I have the same problem, and even if I try to uninstall (manually or with Revo Uninstaller) the 4.9.2.27 version I receive an error. So basically I cannot uninstall or install the new one over this existing version.
You literally posted right after I did so unsure if you saw what I just posted, but try doing what I said. Update us if it helped you.
Reply With Quote


  #14  
Old 12-09-2017, 04:50 AM
OctavianH OctavianH is offline
Registered User
OctavianH's PC Specs
 
Join Date: Oct 2017
Location: Brasov
Posts: 4
POST ID # = 929753
OctavianH Reputation: 10
Default

Worked with the above mentioned hint. Thanks a lot @DeadxWreckoning.
Reply With Quote


  #15  
Old 12-09-2017, 03:41 PM
Dominator01 Dominator01 is offline
Registered User
Dominator01's PC Specs
 
Join Date: Mar 2014
Posts: 42
POST ID # = 929824
Dominator01 Reputation: 10
Default

Quote:
Originally Posted by DeadxWreckoning View Post
I had this same issue. Link installer kept crashing every time I went to install the update, be it thru the old Link version or by downloading the standalone installer. I finally got it to work by closing everything in my app tray - which included Corsair CUE. Can't say for sure if CUE caused it but it's conflicted with Link in the past, recently too. Try closing CUE and other apps in your tray and trying it.
Okay, i tried your advice and be hold it worked, thanks a million.
Reply With Quote


1 members found this post helpful.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.