The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-02-2016, 10:55 AM
thanasis_bimpas thanasis_bimpas is offline
Registered User
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860668
thanasis_bimpas Reputation: 10
Default H80iGT recognised as H100i

Hello Everybody,
I recently purchased an H80iGT watercooler.However Corsair Link has been recognizing it as an H100iGTX.
I contacted the vendor,has them check the cooler and they said that this is normal and all coolers are recognized as H100i.Is that true or is my product defective and they are avoiding replacement?
Also I have tried reinstalling corsair link and drivers and i also did a fresh windows installation but the problem remains,so I suppose it isnt software related.
What should I do?Thanks

Last edited by thanasis_bimpas; 07-02-2016 at 03:52 PM.
Reply With Quote


  #2  
Old 07-02-2016, 12:10 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 860674
red-ray Reputation: 81
Thumbs down This is not normal at all

This is not normal at all, but are you sure it's reported as H100i and not a H100iGTX?

Looking from http://forum.corsair.com/forums/showthread.php?p=785129 you will see a H80iGT was incorrectly loaded with the H100iGTX firmware. What is reported for your cooler?
Reply With Quote


  #3  
Old 07-02-2016, 03:52 PM
thanasis_bimpas thanasis_bimpas is offline
Registered User
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860698
thanasis_bimpas Reputation: 10
Default

I rechecked and yes,it says H100iGTX,I will edit the post
Reply With Quote


1 members found this post helpful.
  #4  
Old 07-02-2016, 03:57 PM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 860699
red-ray Reputation: 81
Arrow Either return it or request an RMA

Quote:
Originally Posted by thanasis_bimpas View Post
I rechecked and yes,it says H100iGTX,I will edit the post
I would either return it or request an RMA via https://corsair.secure.force.com/home/home.jsp.
Reply With Quote


  #5  
Old 07-02-2016, 03:59 PM
thanasis_bimpas thanasis_bimpas is offline
Registered User
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860700
thanasis_bimpas Reputation: 10
Default

I will probably RMA it,since the seller doesent aknowledge this as a problem,and im past the day limit for a return
Reply With Quote


Reply

Tags
corsair link, h80igt, problem, support, watercooler

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.