The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Cooling

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-13-2011, 03:31 PM
Khalitz Khalitz is offline
Registered User
Khalitz's PC Specs
 
Join Date: Jul 2011
Posts: 2
POST ID # = 512850
Khalitz Reputation: 10
Question H80 installation issue, Asus P8Z68

Hello,

I just attemped to install my new H80 cooler.
I fitted the back plate, fastening it with the intel type double sided screws (on which both threads are of equal lengths).

When tightened, however, the back plate is not fixated against the motherboard. It seems that this is because the back plates threads are 0,2mm or so too long and protrude through the motherboard, allowing the double sided screws to tighten against the backplate thread and not the motherboard.

As I searched the forum I noticed the following thread;
http://forum.corsair.com/forums/showthread.php?t=96380

However, either the OP in that tread might have made the same error as me.

This could be my own fault, but I'm not sure. Anyone else with a P8Z68 notice this issue? I'll try to get a couple pictures.
Reply With Quote


  #2  
Old 07-13-2011, 04:06 PM
Khalitz Khalitz is offline
Registered User
Khalitz's PC Specs
 
Join Date: Jul 2011
Posts: 2
POST ID # = 512859
Khalitz Reputation: 10
Default

Looks like I found the answer on my own (my bad!).

According to this thread, what i described above is normal/OK:
http://forum.corsair.com/v3/showthread.php?t=96439

The double sided screws are not needed to fixate against the motherboard, they are there to pull the backplate and pump assembly together.
Obvious, when I think about it now.

Looks good with pump installed. Thermal paste spread looks good after test assembly. Will move on with full assembly now...
Reply With Quote


  #3  
Old 07-13-2011, 07:44 PM
pancakepaddle pancakepaddle is offline
Nooblike
pancakepaddle's PC Specs
 
Join Date: Jul 2011
Posts: 55
POST ID # = 512888
pancakepaddle Reputation: 10
Default

Hey man whats up. So you got the new z68? How is it? I hear you can utilize the built in on board gpu. Testing shows that it performs as well as a gtx 590 in an ssd type set up so I read. Is this true?
Reply With Quote


  #4  
Old 08-02-2011, 07:48 PM
DoOkie DoOkie is offline
Registered User
 
Join Date: Jul 2011
Posts: 8
POST ID # = 517066
DoOkie Reputation: 10
Default

Heh I just came here for the same reason(H80 on Asus Z68). I guess everything worked out for you...

Well, back to building. I guess. ;)

Update: Works fine after installing block. Nice and snug. Cleared everything on Asus P8Z68 Deluxe. ;)

Last edited by DoOkie; 08-02-2011 at 08:26 PM.
Reply With Quote


Reply

Tags
h80, installation, p8z68

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.