The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-31-2012, 11:04 AM
Nephelion Nephelion is offline
Registered User
 
Join Date: Dec 2012
Posts: 2
POST ID # = 622680
Nephelion Reputation: 10
Angry Corsair Vengeance 2000 not pairing

Hello,

I've been given this headset for Holidays but i have issues getting it work properly. For one week now, i couldn't get it paired with the dongle, i had to use the "recessed pairing button" EVERYTIME i shut down my computer, and after pushing it for one week everytime i used my headset (by the way this button is SO inconvenient) i don't know if i broke it but it doesn't work anymore. So right now i CAN'T get my headset working...

I tried:

-I DID charge the battery until the light became green before any use
-Installing drivers
-Uninstalling - rebooting - installing - rebooting
-The recessed pairing button like explained in the FAQ
-Every USB port
-Plugging - unplugging everything

I don't know what's going on. Yesterday it was still working fine (EXCEPT I had to use the button) but this morning the pairing button didn't work so i can't pair them. I don't understand why they don't automatically pair like explained in the user guide, and also it is said IN CASE i had to use the button i would just use it ONCE, not everytime...

Right now both the dongle and the headset are blinking blue. I'm using W7 64bits.

Ask me if you need more informations.

If someone has ANY clue, even if you think of something very stupid i could have forgot...

Last edited by Nephelion; 12-31-2012 at 11:09 AM.
Reply With Quote


  #2  
Old 01-01-2013, 05:57 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 622783
Toasted Toasted Reputation: 108
Default

Try pairing it on another computer and see if it will pair automatically after the computer shuts down.

If it still doesn't pair. The dongle might be faulty. Request an RMA to replace it.
Reply With Quote


  #3  
Old 01-01-2013, 08:39 AM
Nephelion Nephelion is offline
Registered User
 
Join Date: Dec 2012
Posts: 2
POST ID # = 622795
Nephelion Reputation: 10
Default

I had also tried this and still not working. I think i'll do what you say :(
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.